buildworld failure r223619 to 225128

Beach Geek labeachgeek at
Sat Aug 27 15:16:32 UTC 2011

On 8/25/11, Dimitry Andric <dim at> wrote:
> On 2011-08-25 17:12, Beach Geek wrote:
>> make buildworld failed trying to upgrade from r223619 to r225128.
>> (Note: Updating other boxes from r224774 to r225119 went flawless)
>> On failing laptop (Toshibs Sat C655D)
> ....
>> /usr/include/c++/4.2/bits/stringfwd.h:56: internal compiler error:
>> Segmentation fault: 11
>> Please submit full report,
> That is most likely a hardware problem.  Please run a full memtest,
> and/or any other hardware diagnostics you can find.
> It could also be running out of memory, but that is less likely, and you
> usually get another signal then.  But who knows what might happen if you
> choke a compiler. :)
>> I do "rm -r /usr/obj/*" and make clean (in /usr/src)  before doing
>> buildworld on all boxes.
>> I also tried compiling new GENERIC kernel then doing buildworld.  It
>> failed with same message.
> It dies on exactly the same file?
>> Reverted to old/original kernel and tried "make depend" in /usr/src.
> You can't do that, you must run buildworld.
>> It failed with... (by hand again)
>> ===>  lib/clang/libllvmarmasmparser (depend)
>> tblgen -l
>> /usr/src/lib/clang/libllvmarmasmparser/../../../contrib/llvm/lib/Target/ARM
>> -I /usr/src/lib/clang/libllvmarmasmparser/../../../contrib/llvm/include
>> -I /usr/src/lib/clang/libllvmarmasmparser/../../../contrib/llvm/lib/Target
>> -gen-asm-matcher -o ARMGenAsm
>> /usr/src/lib/clang/libllvmarmasmparser/../../../contrib/llvm/lib/Target/ARM/
>> tblgen: Record 'CCR', field 'MemberList' does not have a list initializer!
>> *** Error code 1
>> Stop in /usr/src/lib/clang/libllvmarmasmparser.
> Yes, this is expected.  When you do not use the buildworld target, the
> tblgen used above will be run from /usr/bin, which is too old.  This is
> why buildworld first builds an up-to-date tblgen under /usr/obj, and
> uses that to generate the needed files.

This laptop also runs MS Win 7/64 and FreeBSD 9 amd.  The FBSD amd upgraded ok.

The buildworld always fails in same place, with same message (5 tries).
I'm running diags on it right now just to make sure the hardware's good.

The reason I tried "make depend" was because of a reference to r221543
that said it required "make depend" before buildworld.  (a shot in the
dark before posting to mail list).

I will post if I find any hardware problems.

Beach Geek

PS. Option on updating to a version inbetween, then to latest???

More information about the freebsd-current mailing list