files/dd7c394c9c9ddf4b97f1b14c676f370adc259b2c7a4b8346eba0788a431db398.gz not found -- snapshot corrupt.

Hartmann, O. ohartman at
Sun Aug 14 10:17:50 UTC 2011

On 08/14/11 11:48, Niclas Zeising wrote:
> On 2011-08-13 12:08, Roland Smith wrote:
>> On Sat, Aug 13, 2011 at 09:51:41AM +0200, Hartmann, O. wrote:
>>> On 08/13/11 09:26, Roland Smith wrote:
>>>> On Sat, Aug 13, 2011 at 12:43:52AM +0200, Hartmann, O. wrote:
>>>>> On 08/12/11 22:54, Roland Smith wrote:
>>>>>> On Fri, Aug 12, 2011 at 08:44:07PM +0200, Hartmann, O. wrote:
>>>>>>>>> files/dd7c394c9c9ddf4b97f1b14c676f370adc259b2c7a4b8346eba0788a431db398.gz
>>>> Does this file actually exist if you extract the snapshot? And are the
>>>> permissions et cetera OK?
>>>> Roland
>>> No, it does not.
>>> What I did so far over night:
>>> I deleted /var/db/portsnap as well as /usr/ports/. Then I tried again.
>>> Again failure.
>>> After that it got the ports tree via CVS (make update in /usr/ports).
>>> Everything seems
>>> all right. I tried portsnap again. portsnap compalins about a
>>> non-portsnap-created /usr/ports
>>> and please me to use 'extract'. I do ... but then I run into the very
>>> same failure:
>>> (portsnap fetch extract:)
>>> /usr/ports/devel/cccc/
>>> /usr/ports/devel/ccdoc/
>>> /usr/ports/devel/ccrtp/
>>> /usr/ports/devel/cdash/
>>> files/dd7c394c9c9ddf4b97f1b14c676f370adc259b2c7a4b8346eba0788a431db398.gz not
>>> found -- snapshot corrupt.
>> I've been looking at the portsnap shellscript. This error message is generated
>> by the shell's built-in test command, specifically '[ -r'. It is looking for a
>> file that was extracted with tar. So the place to look for the bug is IMO
>> 1) the portsnap script itself (differences between 8.2 and 9?)
>> 2) the sh(1)'s built-in test command (ditto)
>> 3) tar (ditto)
>> When you run 'portsnap fetch' it downloads a tgz archive and unpacks it with
>> tar(1). What you could try is to comment out the line 'rm ${SNAPSHOTHASH}.tgz'
>> in portsnap, and test if the tgz file extracts differently using an
>> 8.2-RELEASE tar and the 9-CURRENT tar.  If so, that would be a bug!
>> Roland
> Just a "me too!". It happens for me on a recently updated 9-current
> virtual machine, built with clang.
> Regards!

Just got a notebook, build with the old gcc 4.2 of the system FreeBSD 
9.0/amd64 -r224579: portsnap works as expected.

I will build a most recent system on that box (with systems's outdated 
gcc 4.2) and I'll report if the problem is still present.

By the way: My boxes of failure are all built with CLANG.


More information about the freebsd-current mailing list