resolvconf script overwrites entries in resolv.conf - RDNSS/DNSSL related

Hajimu UMEMOTO ume at
Wed Aug 10 07:29:47 UTC 2011


>>>>> On Mon, 08 Aug 2011 16:42:06 +1000
>>>>> Mattia Rossi <mrossi at> said:

mrossi> Anyhow, the manpage is really not clear about name_servers_append, and
mrossi> it's not working as expected either:

mrossi> 1) If I put in a comma separated list of nameservers, I'll find that
mrossi> comma separated list in /etc/resolv.conf under a single "nameserver"
mrossi> tag. That doesn't work, as it's not a valid entry. Each nameserver
mrossi> needs to have a "nameserver <host>" entry.

name_servers and name_servers_append is a space separated list of

mrossi> 2) If I use multiple name_servers_append entries in
mrossi> /etc/resolvconf.conf, then only the last entry is used. I don't want
mrossi> only one DNS server there though, I want all three of them, as I
mrossi> already had the problem that one or the other didn't work properly.

You can specify multiple nameservers in name_servers and/or

mrossi> 3) If I read the description for name_servers in resolvconf.conf(5), I
mrossi> understand that this tag prepends the nameserver to my list. This is
mrossi> not what happens. Still not sure what actually happens there...

It is strange to me.  If you specify name_servers, it should be
prepended to the nameserver list.  I've just tried name_servers, and
it did the job as expected, here.

mrossi> How do I get my 3 manual DNS entries properly into my resolv.conf ?

Please specify your 3 servers as space separated list in name_servers
or name_servers_append.


Hajimu UMEMOTO @ Internet Mutual Aid Society Yokohama, Japan
ume at  ume@{,jp.}

More information about the freebsd-current mailing list