[SPAM] Re: Error message while updating src for FreeBSD 9 current

Ralph Ellis ralphellis1 at netscape.ca
Fri Sep 24 05:10:27 UTC 2010

Niclas Zeising wrote:
> On 2010-09-23 14:02, Bartosz Stec wrote:
>> On 2010-09-23 13:36, Niclas Zeising wrote:
>>> On 2010-09-23 13:21, Ralph Ellis wrote:
>>>> Niclas Zeising wrote:
>>>>> On 2010-09-23 04:29, Ralph Ellis wrote:
>>>>>> Hi,
>>>>>> I recently upgraded my FreeBSD 8.1 installation to FreeBSD 9
>>>>>> current via
>>>>>> buildworld and buildkernel. I was able to one general ports, src
>>>>>> and doc
>>>>>> update by cvsup but now I am getting the following error message
>>>>>> when I
>>>>>> do a src update.
>>>>>>> cvsup srcsupfile
>>>>>>> Connected to cvsup2.FreeBSD.org
>>>>>>> Updating collection src-all/cvs
>>>>>>> Edit src/bin/ps/extern.h
>>>>>>> Illegal instruction
>>>>>> I am new to the mailing list. Is this a known error?
>>>>>> Is this an error to do with the source tree or an issue on my end?
>>>>>> Just for reference, the contents of my supfile are
>>>>>> *default tag=.
>>>>>> *default host=cvsup2.FreeBSD.org
>>>>>> *default prefix=/usr
>>>>>> *default base=/var/db
>>>>>> *default release=cvs delete use-rel-suffix compress
>>>>>> src-all
>>>>>> ports-all
>>>>>> doc-all
>>>>>> Thanks in advance for your assistance,
>>>>>> Ralph Ellis
>>>>>> ralphellis1 at netscape.ca
>>>>> Are you using cvsup or csup? Have you recompiled cvsup in case you 
>>>>> use
>>>>> that? What's in your make.conf file?
>>>>> Illegal instruction is usually because the program is compiled for
>>>>> another CPU than what it's running on. It can also be that syscalls
>>>>> has changed, but then it usually complains about that.
>>>>> When doing a major version upgrade, you usually have to recompile all
>>>>> ports.
>>>>> Hope this helps!
>>>>> //Niclas
>>>> I am using cvsup. I had recompiled my VirtualBox port but I had not
>>>> finished recompiling the other major ports. Thanks for the suggestion.
>>>> My make.conf is deliberately very plain jane with no special 
>>>> conditions
>>>> or comments.
>>>> Thanks
>>>> Ralph Ellis
>>>> ralphellis1 at netscape.ca
>>> Try to recompile everything, or at least cvsup, and see if it works.
>>> //Niclas
>> Niclas, did you perform 'make delete-old && make delete-old-libs' after
>> upgrade to CURRENT? If you did, many of your ports won't longer work
>> properly (or at all) because of missing libraries. If you didn't, you
>> definitely should do something like 'portupgrade -afrRi' and after you
>> done, you can get rid of these old files with commands above.
> You wouldn't get illegal instruction then though. Usually the 
> application fails to load if dynamic libraries are missing.
>> Of course it could take VERY long time depending on installed ports and
>> machine spec., so if you just need to get your sources updated quickly I
>> recommend:
>> 1. Try csup instead of cvsup. It's integrated in both 8.x and in
>> CURRENT, so should work "out of the box"
> That's a good idea.
>> 2. If you (for some strange reasons) want to stick to cvsup, you'll
>> probably make it work again by portupgrade -fR 'cvsup*'
>> 3. another approach is to get cvsup binaries from package instead of
>> compiling ports - check man pkg_add
>> 4. If you need cvsup to update ports tree, try portsnap instead. It's
>> faster and smarter, and integrated with system :) - check man portsnap
>> Good luck!
> //Niclas
> _______________________________________________
> freebsd-current at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-current
> To unsubscribe, send any mail to 
> "freebsd-current-unsubscribe at freebsd.org"
Thanks for all the helpful suggestions.
csup worked like a charm and solved the problem.  I will be rebuilding 
my ports gradually, starting with the development ports like Perl, gcc, 
clang etc.

I am also experimenting with a custom kernel where I am eliminating 
drivers and modules for isa, wireless devices and hardware only found on 
laptops.  The early results are encouraging. I run Folding at home in a 
VirtualBox with Unbuntu x64 as a guest OS. Since trying a custom kernel, 
floating point performance has improved over 20%.  This may also be due 
to some kernel improvements in FreeBSD 9. So far I am very impressed 
with the stability of the OS. I have not had problems with any of the 
programs that I run on a regular basis. I had expected to hit more bugs.
I will get started on the rebuilds but with 1700 ports installed, I will 
wait for a free weekend to compile the big stuff.
Thanks again
Ralph Ellis
ralphellis1 at netscape.ca

More information about the freebsd-current mailing list