Timer panic on boot (r209434)

Doug Barton dougb at FreeBSD.org
Tue Jun 22 21:00:21 UTC 2010

On 06/22/10 13:10, Alexander Motin wrote:
> Doug Barton wrote:
>> On 06/22/10 12:55, Doug Barton wrote:
>>> Howdy,
>>> I tried upgrading from r209351 to r209434 and got a panic related
>>> to the timer stuff while booting. You can see the panic and the
>>> backtrace here:
>>> http://people.freebsd.org/~dougb/timer-panic-1.jpg 
>>> http://people.freebsd.org/~dougb/timer-panic-2.jpg 
>>> http://people.freebsd.org/~dougb/timer-panic-3.jpg
>> Hmmm, that could use a little more detail. :)  I have a Dell laptop
>> with a core 2 duo processor, running 9-current SMP i386.
> Your ACPI seems reports that attimer uses IRQ2, instead of usual
> IRQ0. It is either a bug, or it is a very rare feature.
> I am not sure it is not a hack, but you may try attached patch.

Ok, I updated to r209441, then applied your patch. FYI, I applied it in
src/sys/x86/isa/ using -p2. This allowed me to boot, verbose dmesg is at

> If it helps, it would be nice it you tried to use i8254 event timer,
> to check is this a bug or feature.

Ok, I'm willing to give that a try if you tell me how. :)



	... and that's just a little bit of history repeating.
			-- Propellerheads

	Improve the effectiveness of your Internet presence with
	a domain name makeover!    http://SupersetSolutions.com/

More information about the freebsd-current mailing list