r209240 ia64 -> buildworld -> undefined reference to `lzma_physmem'

jhell jhell at dataix.net
Mon Jun 21 19:20:46 UTC 2010

On 06/21/2010 13:47, Dag-Erling Smørgrav wrote:
> jhell <jhell at dataix.net> writes:
>> As to the point before you start pointing fingers as you are so gracious
>> to do lately - The steps laid out are the steps I had once took to
>> correct the similar problem. And I seem to be running on these systems
>> fairly well mind you.
> They are still wrong, and they will not solve his problem.  All they
> will do is muddle the tracks and reduce our chances of ever finding out
> what the problem really is.

Actually I apologize as I originally read your fix to what I posted as
cd to /usr/src/includes where as you are correct with those build
options for a cd /usr/src. I do think that a full depends and includes
build for the whole tree is a little expensive in this case but it would
work the same either way.

Though with what you said above (second paragraph) I would believe that
trying to correct this problem first by finding out if the problem was
laid out in the includes directory first would have been one step
possibly in the right direction to solving the problem as I am just
trying to recall what had actually solved that import of lzma issue.

This is the thread with the discussion:

Why on earth this is breaking on some machines and not on others is
weird. Maybe a possibility of having the xz- port installed in
comparison to the ones that don't... I didn't have that much time to
analyze it when it came about.

I can say that after he tried the build after the includes directory
build that the `lzma_physmem' error he was getting in the subject line
disappeared and he was left with just having to update libarchive & liblzma.

>> Praying for you,
> I'd rather you didn't.

In reference to: http://bit.ly/dy4VSb




More information about the freebsd-current mailing list