amd64 panic snd_hda - hdac_get_capabilities: Invalid corb size (0)

Lawrence Stewart lstewart at
Tue Jul 27 07:37:52 UTC 2010

On 07/27/10 02:07, Anton Shterenlikht wrote:
> On Mon, Jul 26, 2010 at 02:24:52PM +0100, Anton Shterenlikht wrote:
>> On amd64 r210496 I get this panic when booting a kernel
>> with snd_hda(4). I haven't used this driver before, so
>> can't say if this is a regression.
>> (copied by hand)
>> hdac0: <ATI SB600 High Definition Audion Controller> irq 16 at device 20.2 on pci0
>> hdac0: HDA Driver Revision: 20100226_0142
>> hdac0: [ITHREAD]
>> hdac0: hdac_get_capabilities: Invalid corb size (0)
>> device_attach: hdac0 attach returned 6
>> Slab at 0xffffff000261eb18, freei 3 = 0
>> panic: Duplicate free of item 0xffffff0002661c00 from zone 0xffffff00b7f9a500(1024)
>> cpuid = 0
>> KDB: enter: panic
>> [ thread pid 0 tid 100000 ]
>> Stopped at kdb_enter+0x3d: movq      $0,0x74f360(%rip)
>> db>bt
>> (very long output.. ending in)
>> mi_startup() at mi_startup_0x59
>> btext() at btext+0x2c
> I moved back as far as r204000, still the same panic.
> Please advise

I get this same panic on my Toshiba Portege R600 laptop when I boot it
into Windows and then reboot it into FreeBSD. My guess is that the
Windows drivers leave the hardware in a state which the FreeBSD code
doesn't know how to deal with. I don't run Windows often so haven't hit
this panic in a while, but the trick that always worked for me was to go
into the BIOS and "Reset to defaults", then boot into FreeBSD.


More information about the freebsd-current mailing list