Can't compile today's kernel: sys/cam/cam.c + CTF

Navdeep Parhar nparhar at
Fri Jul 23 22:44:44 UTC 2010

On Fri, Jul 23, 2010 at 3:40 PM, Doug Barton <dougb at> wrote:
> On Fri, 23 Jul 2010, Navdeep Parhar wrote:
>> On Fri, Jul 23, 2010 at 3:22 PM, Doug Barton <dougb at> wrote:
>>> I'm getting this with r210435. World built fine:
>>> cc -c -x assembler-with-cpp -DLOCORE -O -pipe  -std=c99 -g -Wall
>>> -Wredundant-decls -Wnested-externs -Wstrict-prototypes
>>> -Wmissing-prototypes
>>> -Wpointer-arith -Winline -Wcast-qual  -Wundef -Wno-pointer-sign
>>> -fformat-extensions -nostdinc  -I. -I/usr/local/src/sys
>>> -I/usr/local/src/sys/contrib/altq -D_KERNEL -DHAVE_KERNEL_OPTION_HEADERS
>>> -include opt_global.h -fno-common -finline-limit=8000 --param
>>> inline-unit-growth=100 --param large-function-growth=1000
>>>  -mno-align-long-strings -mpreferred-stack-boundary=2 -mno-mmx -mno-3dnow
>>> -mno-sse -mno-sse2 -mno-sse3 -ffreestanding -fstack-protector -Werror
>>> /usr/local/src/sys/i386/i386/locore.s
>>> cc -c -O -pipe  -std=c99 -g -Wall -Wredundant-decls -Wnested-externs
>>> -Wstrict-prototypes  -Wmissing-prototypes -Wpointer-arith -Winline
>>> -Wcast-qual  -Wundef -Wno-pointer-sign -fformat-extensions -nostdinc -I.
>>> -I/usr/local/src/sys -I/usr/local/src/sys/contrib/altq -D_KERNEL
>>> -DHAVE_KERNEL_OPTION_HEADERS -include opt_global.h -fno-common
>>> -finline-limit=8000 --param inline-unit-growth=100 --param
>>> large-function-growth=1000  -mno-align-long-strings
>>> -mpreferred-stack-boundary=2 -mno-mmx -mno-3dnow -mno-sse -mno-sse2
>>> -mno-sse3 -ffreestanding -fstack-protector -Werror
>>> /usr/local/src/sys/cam/cam.c
>>> *** Signal 11
>>> Removing makeoptions     WITH_CTF=yes does the trick.
>> I ran into this earlier today.  ctfconvert would dump core during
>> buildkernel.
>> Please try r210438
> I updated to that revision, tried just rebuilding ctfconvert, didn't work.
> Then I tried installing the new ctfconvert, still doesn't work. Do I need to
> go farther up the tree?

Hmm.  I think a "make toolchain" in /usr/src before you build your
kernel should fix it.  You probably have an old ctfconvert sitting


More information about the freebsd-current mailing list