msk(4) cannot receive packets on Marvell Yukon 88E8057

Pyun YongHyeon pyunyh at
Sat Jul 10 22:50:07 UTC 2010

On Sat, Jul 10, 2010 at 11:19:27AM -0400, Ryan Stone wrote:
> I just got a new laptop that has a Marvell Yukon 88E8057 ethernet
> adapter.  The msk driver attaches to the hardware on the 8.1 release
> candidate, and I seem to be able to transmit packets just fine, but I
> can't receive packets reliably.  The first time I tried the driver a
> couple of pings succeeded, but dhcp didn't and now that I've tested
> for a while longer, it seems that the first ping succeeding was pure
> luck.

Established link speed is 1000Mbps, right?
I guess 100Mbps may work if link partner is configured to use 100Mbps.

> Does anybody have ideas on where to start debugging this?  I'm willing
> to test patches, gather more information and basically do whatever it
> takes to get this working, as the laptop isn't too useful to me
> without networking.

Controllers that have 88E1149 PHY seems to have issues. Lack of
hardware access and data sheet also makes it hard to fix that.
Several patches I tried via remote debugging didn't help at all.
ATM I have no clue why it happens on some controllers. Sorry.

More information about the freebsd-current mailing list