running old binaries on -current

Kostik Belousov kostikbel at
Fri Jul 2 18:44:35 UTC 2010

On Fri, Jul 02, 2010 at 11:12:13AM -0700, Julian Elischer wrote:
> every now and then, for fun I run up a chroot of freebsd 1.1. or 1.0 
> under a chroot.  Usually hillarity ensues with teh 15 second kernel 
> compile and the 4 minute make world.
> in -current I can't do that any more.. any binary just exits with 'Abort'.
> I think I last tried it in 7.0 or there abouts.
> does anyone else have any ideas as to what may be needed?
> I vaguely remember another option but I am not seeing it at the moment.
> For those of you who do not remember, 1.0 had a.out static binaries only.

Can you ktrace/kdump the run attempt, I suspect that abort is
sent by image activator.

Also, please put some static binary somewhere to download.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
Url :

More information about the freebsd-current mailing list