Panic @r207433: "System call fork returning with the following locks held"

David Wolfskill david at
Fri Apr 30 17:06:06 UTC 2010

On Fri, Apr 30, 2010 at 07:27:32PM +0300, Kostik Belousov wrote:
> ...
> Please try r207438.

OK; that worked -- thanks!

I actually merely hand-edited the one file & rebuilt the kernel; boot to
multi-user mode was uneventful, and:

FreeBSD 9.0-CURRENT FreeBSD 9.0-CURRENT #145 r207433M: Fri Apr 30 09:54:26 PDT 2010     root at  i386

I also completed the CURRENT build on my laptop, and despite what
happened with the build machine, I tried booting r207433 ... and
it came up just fine.  Biggest salient difference that occurs to
me is that the laptop is a single core, while the build machine is
a pair of CPUs (with a single core each):

FreeBSD 9.0-CURRENT FreeBSD 9.0-CURRENT #144 r207433: Fri Apr 30 09:06:04 PDT 2010     root at  i386

Thanks again for the timely fix!

David H. Wolfskill				david at
Depriving a girl or boy of an opportunity for education is evil.

See for my public key.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
Url :

More information about the freebsd-current mailing list