ANY-ONE-ELSE? ntpd+oncore+i386 doesn't work

Ian FREISLICH ianf at
Wed Apr 21 08:38:08 UTC 2010


The oncore ntp driver worked fine in my Athlon64 machine running
FreeBSD-amd64.  I've tried it on a VIA-C7 and a Pentium-M based
board with an onboard serial port.

The following patch from Russell J. Yount fixes (bandaids) the issue:

Index: /usr/src/contrib/ntp/ntpd/refclock_oncore.c
RCS file: /home/ncvs/src/contrib/ntp/ntpd/refclock_oncore.c,v
retrieving revision 1.2
diff -u -d -r1.2 refclock_oncore.c
--- /usr/src/contrib/ntp/ntpd/refclock_oncore.c 22 Aug 2008 15:58:00 -0000     1.2
+++ /usr/src/contrib/ntp/ntpd/refclock_oncore.c 21 Apr 2010 08:33:55 -0000
@@ -1127,7 +1127,7 @@
        FILE    *fd;
-       char    *cp, *cc, *ca, line[100], units[2], device[20], Msg[160], **cpp;
+       char    *cp, *cc, *ca, line[100], units[2], device[32], Msg[160], **cpp;
        char    *dirs[] = { "/etc/ntp", "/etc", 0 };
        int     i, sign, lat_flg, long_flg, ht_flg, mode, mask;
        double  f1, f2, f3;


Ian Freislich

More information about the freebsd-current mailing list