FreeBSD kernel doesn't boot on FUJITSU PRIMERGY RX200 S5 server

Maxim Sobolev sobomax at
Tue Apr 20 07:40:44 UTC 2010


For the first time in many years, I've stumbled across a server hardware 
where FreeBSD kernel refuses to boot. It's FUJITSU PRIMERGY RX200 S5 
server with 2x Quad core E5520 processors and 16GB of RAM. Linux boots 
on that hardware just fine. Linux dmesg is available here:

I tried 7.3-RELEASE and latest HEAD, both amd64 and i386 - neither 
worked. HEAD and 7.3 behaved little bit differently. 7.3 hanged after 
the boot command, HEAD - filled in console with funny blinking characters.

Screenshots with some debug information - SMAP, boot environment 

HEAD/amd64 booting (boot -v):

I have control over that machine, so that I can run some tests on it, 
including building and executing debug kernels. The only thing that I 
don't have access to at the moment is BIOS.

Any ideas on how to investigate and fix that problem are highly appreciated.


More information about the freebsd-current mailing list