FreeBSD 9-CURRENT (and 8.0) on MacMini (rev. 3,1)

Phil Regnauld pr+freebsd-current at
Sun Apr 4 12:54:17 UTC 2010

Hi everyone,

Wasn't sure where to post this, so I'll try here as it involves -CURRENT
as well, and effort is probably best spent there.

Have acquired a MacMini "Server" model (4 GB RAM, 2 x 500 GB disk, and
no optical drive) to build a workshop training server. I am trying
to get FreeBSD to work on this beast, and so far I've had mitigated

Below is the combination of versions that work/don't work.  If it hangs/panics,
it's at boot time.

Boot mode       ACPI      NO ACPI/SAFE

F7.2-R amd64  hang      panic (in swapper)
F7.2-R i386   WORKS, but 2.7 GB visible. PAE kernel panics on starting CPU2
              no-ACPI not tested (not necessary)

F8.0-R amd64  hang            hang
F8.0-R  i386  hang            hang ohci

F8.0-S amd64  hang            hang at ohci early: SMM active, request owner change

F9.0-C amd64  panic acpica    hang on md0: Preloaded image  (Feb 2010 SNAP)
F9.0-C i386   panic acpica    panic acpica
                              Stopped at  kbd_enter+0x3a: movl  $0,kbd_why
                              (USB kbd dead here, cannot backtrace)

Currently I'm running 7.3-STABLE/i386, without PAE, limited to 2.6 GB
RAM. ZFS works like a charm, and so does the built-in ethernet. ACPI
works too, but asmc(4) is not available in 7. cputemp(4) works fine as
well, but I don't think the fans ever change speed (though I succeeded
in building world and kernel multiple times, and the CPU core temp never
exceeded 80 C).

On those that don't work, apart from disabling ACPI, I've attempted
disabling various bits of the HW (sio, atkbdc, fdc, ...) but that hasn't helped
so far.  Also, so advice out there recommends disabling HW in the BIOS, which
a Mac doesn't have.

I checked the archives for anything relevant, and do see that older versions
of the MacMini hardware tend to work (with some quirks), but it amd64's
has always been an issue, it seems.

I've also checked out the following links:


"If your system stops early at boot, try reverting r189055:"

(haven't tried that yet, but since 9.0 doesn't work, I didn't see the point).

So, anyway, I'd like to get -CURRENT or even 8-STABLE to work on this.
I'm ready to spend time helping whoever can guide me in debugging this critter.
DDB is a bit tricky since the USB tends to hang as well, and I can't break
into the debugger, or the keyboard doesn't work in it.

I can include verbose boot logs, test any kernel (setting up PXE boot env).
I could file PRs (but would like to refrain from doing this until I'm sure
I've tried the right steps and avoid polluting the PR DB with redundant tickets).

Any help appreciated!


More information about the freebsd-current mailing list