CURRENT && HDA Driver Revision: 20090401_0132 && no recording

Matthias Apitz guru at
Fri May 29 13:49:59 UTC 2009

El día Sunday, May 17, 2009 a las 12:36:48AM +0300, Alexander Motin escribió:

> Matthias Apitz wrote:
> >I can't get to work recording in environment -CURRENT && HDA Driver
> >Revision: 20090401_0132
> >
> >the sound output is fine in KDE, but as well the KDE mixer does
> >not control it; only with mixer(1) command I can change the volume for
> >example; I've already tried all values for setting
> >
> >$ mixer =rec rdev
> >
> >but nothing helps switching on the micro. The man page of snd_hda(4)
> >explains a lot of device.hints(5) options, but understanding all this is
> >out of my control; I'm attaching a 'dmesg | fgrep hdac'.
> >
> >Any idea how to get recording switched on? I need this for business for
> >Skype... This is the last blocking point to switch over to my new Dell
> >M4400
> You have 3 recording sources available via 2 pcm devices. As I can see, 
> your built-in mic assigned to pcm1 device. Have you tried to record from 
> pcm1?
> PS: `dmesg | fgrep pcm` is also interesting.

As said already, recording from the mic jack for the headset works fine
(even without local echo to headset or loudspeaker). How could I record
from the built-in mic, i.e. without the headset plug'ed in into the mic

I'm attaching 'dmesg | fgrep pcm' as well. Thanks for a hint.


pcm0: <HDA IDT 92HD71B7 PCM #0 Analog> at cad 0 nid 1 on hdac0
pcm1: <HDA IDT 92HD71B7 PCM #1 Analog> at cad 0 nid 1 on hdac0
pcm2: <HDA IDT 92HD71B7 PCM #2 Digital> at cad 0 nid 1 on hdac0
Matthias Apitz
t +49-89-61308 351 - f +49-89-61308 399 - m +49-170-4527211
e <guru at> - w
People who hate Microsoft Windows use Linux but people who love UNIX use FreeBSD.

More information about the freebsd-current mailing list