usb keyboard detected after mountroot

Volker volker at
Thu May 28 22:22:16 UTC 2009

On 12/23/-58 20:59, Andriy Gapon wrote:
> I think it's time to remind of this issue again.
> I have no clue why it happens but on my system I consistently see that my USB
> keyboard is detected after mountroot. This worries me because this is a "legacy
> free" system, i.e. it has no PS/2 ports. So if something unexpected happens I
> won't be able to enter different boot device should kernel boot ever stop at
> mountroot prompt.
> Some details.
> With stable/7 I see that my USB mouse is consistently detected way before
> mountroot. But the USB keyboard most often is detected after mountroot. But
> sometimes, very infrequently, it is detected at the same time as the mouse.
> With recent current (and HPS USB, of course) I see that both of the USB devices
> are consistently detected after mountroot:
> ...
> Trying to mount root from zfs:pond/ROOT/original
> ct_to_ts([2009-05-26 18:17:07]) = 1243361827.000000000
> start_init: trying /sbin/init
> ugen2.2: <Logitech> at usbus2
> ugen6.2: <CHESEN> at usbus6
> ukbd0: <CHESEN USB Keyboard, class 0/0, rev 1.10/1.10, addr 2> on usbus6
> kbd2 at ukbd0
> kbd2: ukbd0, generic (0), config:0x0, flags:0x3d0000
> ums0: <Logitech USB-PS/2 Optical Mouse, class 0/0, rev 2.00/24.30, addr 2> on usbus2
> ums0: 8 buttons and [XYZ] coordinates ID=0
> uhid0: <CHESEN USB Keyboard, class 0/0, rev 1.10/1.10, addr 2> on usbus6


I think this is related to an issue I was experiencing two days ago. I
tried to boot an 8.0-CURRENT system off an USB thumb drive and it worked
fine on some machines, but failed with mounting root (off the thumb
drive) on some others.

I think we need some more delay to give drivers the chance to complete
device probing before the root mount is being tried but I hate to just
blindly hack a delay somewhere. Will check that issue, eventually next week.


More information about the freebsd-current mailing list