[Call For Testing] VirtualBox for FreeBSD! take2

Gustau Pérez gperez at entel.upc.edu
Fri May 22 07:38:15 UTC 2009

Hash: SHA1

>>    Last version fixed the problem with the kernel module not being
>> detected the second time vbox is run, but I still have vbox booting
>> the
>> virtual machine in wit a gray screen. I've observed the machine is
>> supposed to be running, but making top shows no activity. Also tried
>> VBoxSDL -startvm win (win is the id given to the vmachine, yes I know,
>> it took me little time to give it a name :) ) and the virtual machine
>> shows a black screen. No CPU activity at all. Tried disabling
>> VT-x/AMD-v
>> extensions (the laptop supports VT-x) still no go.
> Same problem here
> FreeBSD chamonix.restart.bel 8.0-CURRENT FreeBSD 8.0-CURRENT #0: Mon
> May 18 16:47:40 CEST 2009
> root at chamonix.restart.bel:/usr/obj/usr/src/sys/CHAMONIX  i386
> I am using nvidia-driver-180.44
> (II) LoadModule: "nvidia"
> (II) Loading /usr/local/lib/xorg/modules/drivers//nvidia_drv.so
> (II) Module nvidia: vendor="NVIDIA Corporation"
>         compiled for 4.0.2, module version = 1.0.0
>         Module class: X.Org Video Driver
> (II) NVIDIA dlloader X Driver  180.44  Mon Mar 23 05:42:54 PST 2009
> (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
> <clip>
> (II) NVIDIA(0): NVIDIA GPU Quadro NVS 285 (NV44GL) at PCI:3:0:0 (GPU-0)
> (--) NVIDIA(0): Memory: 131072 kBytes
> (--) NVIDIA(0): VideoBIOS:
> (II) NVIDIA(0): Detected PCI Express Link width: 1X
> (--) NVIDIA(0): Interlaced video modes are supported on this GPU
> (--) NVIDIA(0): Connected display device(s) on Quadro NVS 285 at
> PCI:3:0:0:
> (--) NVIDIA(0):     FUS P22W-5 ECO (CRT-0)
> (--) NVIDIA(0): FUS P22W-5 ECO (CRT-0): 400.0 MHz maximum pixel clock
> (II) NVIDIA(0): Assigned Display Device: CRT-0
> (II) NVIDIA(0): Validated modes:
> (II) NVIDIA(0):     "1680x1050"
> (II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
> (--) NVIDIA(0): DPI set to (90, 88); computed from "UseEdidDpi" X
> config
> (--) NVIDIA(0):     option
> (==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
> Henri


  I tried starting vbox with current with VBoxSDL --startvm win (win
is the id I gave to the virtual machine).  With that, a black window
appears, but the "Press F12 ..." messages doesn't appear. I checked
with top, and vbox is doing nothing.

 With the same machine (Dell D630) and using 7.2-RELEASE (with nvidia
driver loader, sound, etc ...) , it works (and it is pretty fast,
don't know how could I live with qemu).

  So that makes me think either it is a problem with some config file
(/boot/loader.conf, /etc/syslog.conf, for tunning purposes) or maybe
my version of current. For /boot/loader.conf and /etc/syslog.conf, I
removed the changes I made related to kern.maxdsiz and others, left
kern.hz=100, removed kqemu and aio. I only have usb, ehci and friends,
linux, nvidia and other hardware modules that shouldn't be the source
of the problem.

   Can anyone with current and vbox working tolds us when you guys
updated your sources ? Anyone has an idea what to check, hack ?

   Regards and thanks,


- --
PGP KEY : http://www-entel.upc.edu/gus/gus.asc
Version: GnuPG v2.0.11 (FreeBSD)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the freebsd-current mailing list