[solved][snd_hda][AD1981HD] microphone doesn't work

Andrey andrey.kosachenko at gmail.com
Wed May 20 20:57:50 UTC 2009


Alexander Motin wrote:
> Hi.
> Andrey wrote:
>> There is a laptop with Intel HD Audio Controller on board (HDA Codec 
>> AD1981HD) and FreeBSD8.0 CURRENT installed. Unfortunately I can't get 
>> microphone working. (7.2-PRERELEASE had been used before switching to 
>> CURRENT and microphone had been known as working out-of-the-box on 
>> that version of FreeBSD).
>> Looking through the list exposed message where similar issue was 
>> reported: 
>> http://www.mailinglistarchive.com/freebsd-current@freebsd.org/msg22832.html 
>> But it looks like requestor didn't provide feedback regarding enclosed 
>> patch. Also, as far as I can judge, that patch is already in CURRENT, 
>> but it seems issue is not solved yet (well, at least I think so).
> This patch was merged to 7-stable 4 months ago, together with the rest 
> of driver changes. 7.2-PRERELEASE had snd_hda driver almost (or may be 
> even completely) identical to the CURRENT of that time. So I don't 
> understand the difference. To find any difference in driver operation, 
> try to compare verbose dmesg of the driver in working and not working 
> systems.
> By the way, are you sure that problem is in driver itself? Can't be 
> linuxulator, Skype, settings or whatever else problem? What are you 
> using to record sound? Have you tried to use something trivial like 
> rawrec and rawplay?
> What microphone are you using: external or internal? Have you tried 
> another one? Are you recording silence or some noise? What mixer 
> settings do you use?

sorry for the noise. The real root of the issue was my fault: I selected 
improper recording device for external microphone. (JFR: switching 
recording device to 'monitor' (i.e. 'mixer =rec monitor') was the proper 
setting in my case).

Many thanks to Alexander Motin for helping me to reveal misconfiguration.

Andrey Kosachenko

More information about the freebsd-current mailing list