CURRENT && HDA Driver Revision: 20090401_0132 && no recording

Alexander Motin mav at
Sat May 16 21:36:59 UTC 2009

Matthias Apitz wrote:
> I can't get to work recording in environment -CURRENT && HDA Driver
> Revision: 20090401_0132
> the sound output is fine in KDE, but as well the KDE mixer does
> not control it; only with mixer(1) command I can change the volume for
> example; I've already tried all values for setting
> $ mixer =rec rdev
> but nothing helps switching on the micro. The man page of snd_hda(4)
> explains a lot of device.hints(5) options, but understanding all this is
> out of my control; I'm attaching a 'dmesg | fgrep hdac'.
> Any idea how to get recording switched on? I need this for business for
> Skype... This is the last blocking point to switch over to my new Dell
> M4400

You have 3 recording sources available via 2 pcm devices. As I can see, 
your built-in mic assigned to pcm1 device. Have you tried to record from 

PS: `dmesg | fgrep pcm` is also interesting.

Alexander Motin

More information about the freebsd-current mailing list