Dell M4400 && Xorg-vesa && 1920x1200 res?

Matthias Apitz guru at
Thu May 14 11:19:58 UTC 2009

El día Thursday, May 14, 2009 a las 12:34:04PM +0200, Pieter de Goeje escribió:

> You could try that, but I see that you're running 32bit FreeBSD, which should enable
> you to use te nvidia binary driver (x11/nvidia-driver).
> I know it works excellent on my laptop (i386, 7-STABLE w/ GeForce 8400M).

Thanks for your hint; I've installed this port x11/nvidia-driver and did
what the port requested at the end about /boot/loader.conf and

I run 

# X -configure

and got a fresh xorg.conf created which as well contains 'nvidia' as the

Section "Device"
        Identifier  "Card0"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        BoardName   "Quadro FX 770M"
        BusID       "PCI:1:0:0"

but when I run:

# X -retro -config /root/

X.Org X Server 1.6.0
Release Date: 2009-2-25
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 8.0-CURRENT i386 
Current Operating System: FreeBSD current 8.0-CURRENT FreeBSD 8.0-CURRENT #1: Mon May 11 13:31:04 UTC 2009
guru at current:/usr/obj/usr/src/sys/REBELION-CURRENT i386
Build Date: 28 April 2009  11:44:04AM
        Before reporting problems, check
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu May 14 13:05:56 2009
(++) Using config file: "/root/"
NVIDIA: failed to set MTRR 0xe0000000, 0M (write-combining)
NVIDIA: failed to set MTRR 0xe0000000, 0M (write-combining)

it just hard-locks the system :-(

any idea? could you send me off-list your xorg.conf to check it?

Matthias Apitz
t +49-89-61308 351 - f +49-89-61308 399 - m +49-170-4527211
e <guru at> - w
People who hate Microsoft Windows use Linux but people who love UNIX use FreeBSD.

More information about the freebsd-current mailing list