Rick Macklem rmacklem at
Tue Dec 22 17:44:35 UTC 2009

On Tue, 22 Dec 2009, Andrew Pantyukhin wrote:

> Could I bother you directly with some questions from time to time
> or should I post to a mailing list?
Either. The advantage of using something like freebsd-current@ is that
it ends up in the email archive that others can search and later I
suspect others will start using NFSv4 and be able to help with answers.
(If others get upset w.r.t. the noise, you can blame me:-)

> Here are a few:
> - is ACL support coming to the FreeBSD NFSv4 client?
Good question. As far as I'm aware, all the pieces are in FreeBSD8.0,
but it didn't get tested. (The server wasn't quite there, but should be
soon for freebsd-current using ZFS. At that point, I suspect it'll get
tested. You can be the first!)

> - I can't create Unix domain sockets in a mounted v4 file system
>  in FreeBSD 8.0, is that expected?
I'd say that's a bug. I'll try it here and see what happens.

> - is freebsd-rpcsec.patch coming to our head? Or rather, the
>  dependant functionality (per-user GSS context)
If you are referring to the experimental patch I have for FreeBSD8.0
that does host based initiator credentials from a keytab file, no.
(It's too ugly, but I haven't come up with another way to make it
work yet.) I believe that mounts done by a user (not root) that does
a mount when holding a valid TGT does work without the patch.

> A more general question: I'm currently using v3 (oldnfs) on
> FreeBSD quite extensively — my homedir and lots of other data is
> mounted this way. When I try newnfs, both v3 and v4, they either
> don't allow a desktop environment to start at all, or, if the
> homedir is oldnfs-mounted, newnfs functions for other data for
> some time, and then some problems start. Like, svnsync/csup
> unable to get locks and such. Would you say it is expected
> behaviour or do you consider newnfs mostly production quality
> just a little while from "general deployment"?
> I mean, when do you think you'll be able to unlabel newnfs as
> experimental?
Well, I wasn't aware of client side problems and what I've tested
worked for me. (I'll admit I'm not the sort to use X or gui desktops.)
The NFSv4 locking has worked ok for me against a Solaris10 server, but
I haven't had much opportunity to test against Netapp. If you could
reproduce a case of locking problems with an NFSv4 mount and then
email me the raw tcpdump capture, I can go through the packet trace
under wire shark and see what seems to have happened. (I am trying to
avoid the NLM, since that's dfr@'s world and I know diddly about it.)

I'd guess it's labelled experimental for at least the FreeBSD8 release
cycle, rick

More information about the freebsd-current mailing list