8.0 still doesn't boot in Xen (kern/138863)

Kevin kevin at your.org
Wed Dec 2 22:48:02 UTC 2009

On Nov 24, 2009, at 12:00 PM, Kevin wrote:

> On Nov 24, 2009, at 11:20 AM, Kevin wrote:
>> Is it too late in the 8.0 release schedule to look at kern/138863?  
>> Between 7.x and 8.0 the kernel can no longer boot under Xen due to  
>> changes involving CLFLUSH. The effect is a crash very early in the  
>> boot, with no workaround. (This is under Xen's fully virtualized  
>> mode, not the XEN platform port underway.)
>> This was also mentioned on the Xen mailing lists back in September (http://lists.freebsd.org/pipermail/freebsd-xen/2009-September/000310.html 
>> ) but nothing has been committed to fix this yet.
>> XenServer is getting pretty popular in some enterprise and hosting  
>> environments, so having 8.0 not bootable would be a bit  
>> disappointing. :)
> I was just pointed to the change from a couple of days ago, adding  
> the tunable "hw.clflush_disable". This looks like it might do what I  
> need, so I'm building a new bootable CD to find out and update the PR.
> This should probably be documented somewhere, just so someone in a  
> similar situation even knows about this tunable.
> -- Kevin

Just to follow up, 8.0-RELEASE still doesn't boot for me on XenServer  
5.5.0 on an AMD CPU.

Without setting hw.clflush_disable, I get the same panic as before  
mentioned in the PR. If I do set clflush_disable, I get an endless  
stream of Trap 12 messages, giving instruction pointers all over the  

The last time 8.0 was bootable was in the -BETA timeframe. Does anyone  
have any other suggestions on where to look? It still works fine on  
the same software using an Intel CPU, so somehow that's significant.

-- Kevin

More information about the freebsd-current mailing list