No root filesystem

John Baldwin jhb at
Tue Sep 2 15:34:46 UTC 2008

On Monday 01 September 2008 03:21:16 am Pascal Hofstee wrote:
> On Sat, Aug 30, 2008 at 3:05 AM, Christian Weisgerber
> <naddy at> wrote:
> > John Baldwin:
> >
> >> So the reports I've seen of this all involve the Nvidia MCP55 ATA 
chipset, and
> >> only the ata controller loses its marbles (so to speak).
> >
> > I also observe that k8temp doesn't attach.  Maybe Pascal can check this.
> > It's not part of GENERIC, so k8temp.ko needs to be explicitly loaded
> > by the loader for this.
> >
> > k8temp0: <AMD K8 Thermal Sensors> on hostb3
> Ok .. this morning i went ahead and collected two boot -v logs. One
> for the old (working) kernel and one for the new (broken) kernel. For
> this i made sure not to load the snd_hda module as that tended to
> bloat the verbose boot output beyond the limit that i could still get
> to the interesting data at the next boot. The two verbose bootlogs can
> be found at:
> for the old kernel
> for the new kernel
> for the differences
> between the two.
> The working kernel shows several devices there that do Not show up on
> the new kernel, according to this concerns
> the following devices all by"Advanced Micro Devices"
> -found->        vendor=0x1022, dev=0x1100, revid=0x00
> 0x1100	HyperTransport Technology Configuration
> -found->        vendor=0x1022, dev=0x1101, revid=0x00
> 0x1101	Address Map
> -found->        vendor=0x1022, dev=0x1102, revid=0x00
> 0x1102	DRAM Controller
> -found->        vendor=0x1022, dev=0x1103, revid=0x00
> 0x1103	Miscellaneous Control

This explains k8temp.  So my earlier test patch to Christian only checked on 
i386 which is why it didn't find an issue before.  Try the updated patch at

This does PCI config reads using both methods and panics if it doesn't get the 
same result.

John Baldwin

More information about the freebsd-current mailing list