freebsd 7.0+MCP55 SATA Controler

Miroslav Lachman 000.fbsd at
Mon Mar 3 16:04:07 UTC 2008

Miroslav Lachman wrote:
> Ivan Voras wrote:
>> Andrey V. Elsukov wrote:
>>> This is fourth problem report related to NVIDIA SATA which i saw.
>>> I have MCP55 SATA on my ASUS motherboard and it works fine on
>>> 8.0-CURRENT.
>> As a datapoint, it works fine for me also, during 7-CURRENT, and now for
>> 8-CURRENT, on i386. Is somebody using amd64?
> I am using i386 on 6 machines and amd64 on 1 machine, all FreeBSD 7.0 
> (RC2 or RELEASE) with MCP55 in Sun Fire X2100 M2 without mentioned issues.
> Miroslav Lachman

Today I found that my old backup machine with nForce2 is unbootable with 
FreeBSD 7.0-RELEASE i386 (even from CD!)
Booting hangs on line with "ad2" (HDD detection)
FreeBSD 6.2 (previuously installed on HDD ad2 and upgraded by 
freebsd-update) worked fine.
Now I am in dead point, because I can't rollback - booting with 
kernel.old (6.2 kernel) ends with error message. (I have not the exact 
message, but it is about mounting root fs rw. Root fs is mounted read 
only and if I tried to mount another fs I got "ufs doesn't support the 
new mount syscall", so I think I have 7.0 world booted with 6.2 kernel 
and that's the problem.

Can anybody tell me, how can I rollback binary upgrade if system is in 
this state? (can't boot with 7.0, can't mount with 6.2 kernel)
(freebsd-update was not finished, because machine is unbootable after 
first reboot in upgrade process)

Miroslav Lachman

More information about the freebsd-current mailing list