freebsd 7.0+MCP55 SATA Controler

Andrey V. Elsukov bu7cher at
Mon Mar 3 10:20:08 UTC 2008

Bachilo Dmitry wrote:
> Good day, All.
> I've a little question.
> I have a MCP55 SATA Controler with SATA HDD attached to it and it worked fine 
> on 6.2 until i've decided to install a new system - FreeBSD 7.0
> The system usually doesn't even start from this drive, saying:
> init: cannot run /bin/sh for /etc/rc: invalid exec format
> But sometimes it does and seems to be working, but soon all the services dump 
> cores and the system panics. Getting back to FreeBSD 6.2 solves the problem. 
> I thought it was memory, memtested it, no errors. And after that I've tried 
> to boot 7.0 from this very drive but not through the controller, and it 
> worked.
> Is the driver for this controller broken or am I wrong about the reason?
> Thanks.

This is fourth problem report related to NVIDIA SATA which i saw.
I have MCP55 SATA on my ASUS motherboard and it works fine on
8.0-CURRENT. Can you provide `pciconf -l` output from you system?

WBR, Andrey V. Elsukov

More information about the freebsd-current mailing list