[HEADSUP]: Linux 2.6 emulation enabled on default

Alexander Leidinger Alexander at Leidinger.net
Wed Jun 4 14:34:16 UTC 2008


Quoting Roman Divacky <rdivacky at freebsd.org> (from Tue, 3 Jun 2008  
23:25:11 +0200):

> hi,
>
> today I commited a patch that enabled Linux 2.6 emulation on default
> in contrast to 2.4 as it was until now.

At some point we need a FreeBSD revision bump to be able to determine  
in the ports if we have a default 2.6.16 or a manual 2.6.16. This can  
be now, or at some point in the future when you commit some patches to  
the linuxulator which fix some 2.6 bugs (maybe the ones you specified  
at the end of your mail).

This allows us to switch the default linux_base port upon something  
else than only the linuxlator version (nothing planned yet, but at  
least we have the possiblity then).

Personally I would try to be on the safe side by bumping the freebsd  
version now to denote the transition point. If no showstopper bug  
shows up, we can use this freebsd version value to handle the userland  
side of the linuxulator, if we stumble upon a showstopper bug, we can  
bump the freebsd version again.

Bye,
Alexander.

-- 
http://www.Leidinger.net    Alexander @ Leidinger.net: PGP ID = B0063FE7
http://www.FreeBSD.org       netchild @ FreeBSD.org  : PGP ID = 72077137


More information about the freebsd-current mailing list