Turning COMPAT_43TTY into a binary-only compatibility

Dag-Erling Smørgrav des at des.no
Wed Jan 30 09:51:58 PST 2008


Ed Schouten <ed at fxq.nl> writes:
> Dag-Erling Smørgrav <des at des.no> writes:
> > None of that stuff should be using sgtty.  Linux, for instance, only has
> > termios, not sgtty, so anything that runs on Linux must necessarily
> > already support termios, and it's just a matter of fixing it so it
> > doesn't insist on using sgtty instead.
> That only partially true. Linux supports termios and termio, but it's
> not hard to port termio apps to termios.

Yes, it supports both, but the former has long been deprecated in favor
of the latter, so hopefully only crufty old software should use it.

DES
-- 
Dag-Erling Smørgrav - des at des.no


More information about the freebsd-current mailing list