Problem with nfe stability and throughput

Chris Poulsen mailinglist at nesluop.dk
Wed Jan 16 14:04:53 PST 2008


Hi,

Pyun YongHyeon wrote:
> <snip>
> Based on hardware information from Linux l1 driver I wrote a simple
> PHY driver. You can get the diff at the following URL.
> Would you give it spin?
>
> http://people.freebsd.org/~yongari/atphy.diff
>
> Note, I don't have the hardware so don't know whether it works or
> not. Just compile tested. I also have no PHY hardware information
> so the model name in the driver may not reflect real name.
>
>   
Thank you for your reply. I tried building a new kernel with your patch 
and loaded nfe0 instead of the old rl0 I'm currently using. It came up 
nicely with the following entries in dmesg:

ata3: <ATA channel 1> on atapci0
ata3: [ITHREAD]
nfe0: <NVIDIA nForce MCP67 Networking Adapter> port 0xc880-0xc887 mem 
0xdfefc000-0xdfefcfff,0xdfefe400-0xdfefe4ff,0xdfefe0
00-0xdfefe00f irq 23 at device 10.0 on pci0
miibus0: <MII bus> on nfe0
atphy0: <Atheros F1 Gigabit PHY> PHY 1 on miibus0
atphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT-FDX, auto
nfe0: Ethernet address: 00:1d:60:6d:73:ec
nfe0: [FILTER]
nfe0: [FILTER]
nfe0: [FILTER]
nfe0: [FILTER]
nfe0: [FILTER]
nfe0: [FILTER]
nfe0: [FILTER]
nfe0: [FILTER]
pcib2: <ACPI PCI-PCI bridge> at device 11.0 on pci0
pci2: <ACPI PCI bus> on pcib2

Things seemed to work, so I decided to try and transfer a couple of big 
files to it using ftp. First file went really well, transfer finished 
reporting a transfer speed of 7.68 megabyte/sec - a performance that 
seems ok, taking my network equipment into account ;)

After transferring the file, the ftp client said "entering passive mode" 
preparing for the next file and then things froze up. (Well only the 
network.) The M2N-VM machine stopped responding to ping, ssh, ftp. I 
could not find anything in /var/log/messages, I tried pulling the 
interface down and up, but it didn't bring it back to life.

What do you need me to do, in order to get some usable info about what 
is going on?

--
Regards Chris


More information about the freebsd-current mailing list