Hung laptop now will not boot 7.0-RC1

Scot Hetzel swhetzel at gmail.com
Wed Jan 9 23:16:32 PST 2008


On 1/6/08, Darran <darranc at deejc.net> wrote:
> Hello all,
>
> I downloaded, burnt and installed 7.0-RC1 (all torrent) on amd64
> I downloaded the dell windows drivers for my laptop wireless card (which
> worked on i3686 6.2-RELEASE) and used ndisgen to create the .ko file
> (bcmwl5_sys.ko) and loaded it and then realised I had created the 32 bit
> driver so I re-did it and used the 64 bit file and loaded the 64bit .ko and
> at that point my laptop (Dell Vostro 1000) hung.
> I had put bcmwl5_sys_load="YES" in the loader.conf file
> I rebooted and now I don't get anything. As soon as it starts to boot it
> stops.
> There is a screen showing kernel dump info and I can copy it if needed but I
> have to burn the rescue iso otherwise I cant boot.
>
> Is this a known problem ?
> Does anyone have any advice ?
>
Which driver did you down load from Dell?

I tried Dell's R151519.EXE  XP Driver
(http://ftp.us.dell.com/network/R151519.EXE)

Created bcmwl564_sys.ko module from this windows driver, disabled the
HP bcmwl564_sys.ko driver from loading.  Rebooted the system, and when
I load the Dell bcmwl564)sys.ko driver the following panic occurs:

hp010# kgdb -n 11 kernel.debug

[GDB will not be able to debug user-mode threads:
/usr/lib/libthread_db.so: Undefined symbol "ps_pglobal_lookup"]
GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "amd64-marcel-freebsd".
Ready to go.  Enter 'tr' to connect to the remote target
with /dev/cuad0, 'tr /dev/cuad1' to connect to a different port
or 'trf portno' to connect to the remote target with the firewire
interface.  portno defaults to 5556.

Type 'getsyms' after connection to load kld symbols.

If you're debugging a local system, you can use 'kldsyms' instead
to load the kld symbols.  That's a less obnoxious interface.
During symbol reading...location expression too complex...
During symbol reading, unsupported tag: 'DW_TAG_const_type'.

Unread portion of the kernel message buffer:
ndis0: <Dell TrueMobile 1300 WLAN Mini-PCI Card> mem
0xc0204000-0xc0205fff irq 21 at device 2.0 on pci6
ndis0: [ITHREAD]
ndis0: NDIS API version: 5.1
fpudna in kernel mode!
Kernel page fault with the following non-sleepable locks held:
exclusive sleep mutex HAL preemption lock (HAL lock) r = 0
(0xffffffffd64bff20) locked @
/usr/src/8x/sys-orig/modules/ndis/../../compat/ndis/subr_hal.c:423
KDB: stack backtrace:
db_trace_self_wrapper() at db_trace_self_wrapper+0x2a
witness_warn() at witness_warn+0x248
trap() at trap+0x25e
calltrap() at calltrap+0x8
--- trap 0xc, rip = 0xffffffffd64b4d29, rsp = 0xffffffffd3d86af0, rbp
= 0xffffffffd3d86b30 ---
KeInsertQueueDpc() at KeInsertQueueDpc+0x69
ntoskrnl_timercall() at ntoskrnl_timercall+0xb3
softclock() at softclock+0x2af
ithread_loop() at ithread_loop+0xda
fork_exit() at fork_exit+0x12a
fork_trampoline() at fork_trampoline+0xe
--- trap 0, rip = 0, rsp = 0xffffffffd3d86d30, rbp = 0 ---


Fatal trap 12: page fault while in kernel mode
cpuid = 0; apic id = 00
fault virtual address	= 0x0
fault code		= supervisor read data, page not present
instruction pointer	= 0x8:0xffffffffd64b4d29
stack pointer	        = 0x10:0xffffffffd3d86af0
frame pointer	        = 0x10:0xffffffffd3d86b30
code segment		= base 0x0, limit 0xfffff, type 0x1b
			= DPL 0, pres 1, long 1, def32 0, gran 1
processor eflags	= interrupt enabled, resume, IOPL = 0
current process		= 12 (swi4: clock sio)
panic: from debugger
cpuid = 0
Uptime: 1m36s
Physical memory: 2035 MB
Dumping 161 MB: 146 130 114 98 82 66 50 34 18 2

#0  doadump () at pcpu.h:194
194		__asm __volatile("movq %%gs:0,%0" : "=r" (td));
(kgdb) kldsyms
asf: no kernel modules loaded
(kgdb) list *0xffffffffd64b4d29
No source file for address 0xffffffffd64b4d29.
(kgdb) bt
#0  doadump () at pcpu.h:194
During symbol reading, Incomplete CFI data; unspecified registers at
0xffffffff802c7e7c.
#1  0xffffffff802c83b3 in boot (howto=0x104) at
../../../kern/kern_shutdown.c:417
#2  0xffffffff802c8837 in panic (fmt=Variable "fmt" is not available.
) at ../../../kern/kern_shutdown.c:571
#3  0xffffffff80196127 in db_panic (addr=Variable "addr" is not available.
) at ../../../ddb/db_command.c:444
#4  0xffffffff80196a1f in db_command (last_cmdp=0xffffffff806dbd78,
cmd_table=0x0, dopager=0x1)
    at ../../../ddb/db_command.c:411
#5  0xffffffff80196c30 in db_command_loop () at ../../../ddb/db_command.c:464
#6  0xffffffff80198569 in db_trap (type=Variable "type" is not available.
) at ../../../ddb/db_main.c:228
#7  0xffffffff802f1ab5 in kdb_trap (type=0xc, code=0x0,
tf=0xffffffffd3d86a40) at ../../../kern/subr_kdb.c:510
#8  0xffffffff804c26bd in trap_fatal (frame=0xffffffffd3d86a40,
eva=Variable "eva" is not available.
) at ../../../amd64/amd64/trap.c:718
#9  0xffffffff804c3336 in trap (frame=0xffffffffd3d86a40) at
../../../amd64/amd64/trap.c:250
#10 0xffffffff804a89ae in calltrap () at ../../../amd64/amd64/exception.S:177
#11 0xffffffffd64b4d29 in ?? ()
#12 0xffffffffd3d86b30 in ?? ()
#13 0xffffffff839e9828 in ?? ()
#14 0x00000000000173e7 in ?? ()
#15 0x0000000000000000 in ?? ()
#16 0x0000000000000016 in ?? ()
#17 0x0000000000000008 in ?? ()
#18 0xffffffffd3d86b60 in ?? ()
#19 0xffffffffd64b6ad3 in ?? ()
#20 0xffffffffd3d86b60 in ?? ()
#21 0x0000000000000246 in ?? ()
#22 0x0000000000000010 in ?? ()
#23 0xffffffffc0e40310 in ?? ()
#24 0xffffffffd3d86bc0 in ?? ()
#25 0xffffffff802da07f in softclock (dummy=Variable "dummy" is not available.
) at ../../../kern/kern_timeout.c:279
Previous frame inner to this frame (corrupt stack?)
(kgdb) quit

FreeBSD hp010 8.0-CURRENT FreeBSD 8.0-CURRENT #0: Wed Jan  9 23:47:38
CST 2008     swhetzel at hp010:/usr/src/8x/sys/amd64/compile/DV8135NR
amd64
hp010#

Is this the error that you are getting?


Scot


More information about the freebsd-current mailing list