ssh_exchange_identification: Connection closed by remote host

mouss mouss at
Tue Feb 26 12:18:38 UTC 2008

Juraj Lutter wrote:
> mouss wrote:
>> I tried with secureCRT and with openssh from a netbsd, debian and 
>> centos boxes. same error.
>> I googled for the error, and it seems popular!
>> - I don't think it's an /etc/host* issue, as I was connected to the 
>> box multiple times (and I tried from multiple IPs).
>> - I tried from a vmware hosts with no keys, just to make sure it's 
>> not a key issue.
>> could this be a dns issue? the host is running a "caching" bind. I 
>> would prefer not to disable dns lookup, but if this causes trouble...
> This seems to be more a /etc/hosts.allow issue.

I found the problem:
    fatal: /var/empty must be owned by root and not group or world-writable.
I have created an account and set the home to /var/empty, but this 
changed the owner of /var/empty. sigh.

I should have found
sooner ;-p

thanks to all who responded.

More information about the freebsd-current mailing list