100% of one CPU for nvidia

Derek Ragona derek at computinginnovations.com
Fri Feb 22 09:03:00 UTC 2008


At 12:35 PM 2/21/2008, Zaphod Beeblebrox wrote:
>Has anyone noticed the latest nvidia binary driver driving their interrupt
>load up?  I have:
>
>nvidia0: <GeForce 8700M GT> port 0xef00-0xef7f mem
>0xfd000000-0xfdffffff,0xd0000000-0xdfffffff,0xfa000000-0xfbffffff irq 16 at
>device 0.0 on pci3
>nvidia0: [GIANT-LOCKED]
>nvidia0: [ITHREAD]
>nvidia1: <GeForce 8700M GT> port 0xdf00-0xdf7f mem
>0xf7000000-0xf7ffffff,0xe0000000-0xefffffff,0xf8000000-0xf9ffffff irq 17 at
>device 0.0 on pci4
>nvidia1: [GIANT-LOCKED]
>nvidia1: [ITHREAD]
>
>and
>
>nvidia-driver-169.07 NVidia graphics card binary drivers for hardware OpenGL
>ren
>
>FreeBSD canoe 7.0-RC3 FreeBSD 7.0-RC3 #0: Wed Feb 20 15:19:37 EST 2008
>root at canoe.dclg.ca:/usr/obj/d/64/usr/src/sys/CANOE32  i386
>
>(and 7.3_1 of xorg)
>
>and my top shows the following whenever X is active (note the 43.2%interrupt):
>
>last pid:  9412;  load averages:  1.14,  0.89,  1.84    up 0+13:35:32
>13:33:15
>145 processes: 1 running, 133 sleeping, 11 stopped
>CPU states:  0.2% user,  0.2% nice,  1.7% system, 43.2% interrupt, 54.7%idle
>Mem: 648M Active, 2018M Inact, 309M Wired, 31M Cache, 112M Buf, 181M Free
>Swap: 16G Total, 16G Free
>
>
>My xorg.conf is configured to only use one of the GPU devices.

I have seen this using xorg 7.3.1 with legacy 96 nvidia drivers too.

I didn't have the problem until I went from xorg 7.1 to 7.3.

         -Derek


-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.



More information about the freebsd-current mailing list