DTrace/FreeBSD source snapshot

Greg Olin golin at kineto.com
Wed Feb 6 15:28:35 PST 2008

I ran into this problem as well.  I'm not that familiar with the make
environment and I tried a few changes with John's hint, but I haven't
found the solution.  Can someone say specifically what they did to get
around this problem?


-----Original Message-----
From: owner-freebsd-current at freebsd.org
[mailto:owner-freebsd-current at freebsd.org] On Behalf Of John Birrell
Sent: Saturday, February 02, 2008 2:30 PM
To: Peter Jeremy
Cc: current at freebsd.org
Subject: Re: DTrace/FreeBSD source snapshot

On Sun, Feb 03, 2008 at 08:03:25AM +1100, Peter Jeremy wrote:
> buildworld worked for me but buildkernel blew up:
> --------------------------------------------------------------
> >>> stage 2.3: build tools
> --------------------------------------------------------------
> cd /usr/obj/back/dtrace/src/sys/server;  
> MAKESRCPATH=/back/dtrace/src/sys/dev/ai
> c7xxx/aicasm  make -DNO_CPU_CFLAGS -f
> kefile
> Warning: Object directory not changed from original
> /server
> yacc -b aicasm_gram  -d -o aicasm_gram.c
> /aicasm_gram.y
> yacc -b aicasm_macro_gram -p mm -d -o aicasm_macro_gram.c
> ev/aic7xxx/aicasm/aicasm_macro_gram.y
> cc -O2 -fno-strict-aliasing -pipe -nostdinc -I/usr/include -I.
> c/sys/dev/aic7xxx/aicasm -g  -c
> ctfconvert -L VERSION aicasm.o
> ctfconvert:No such file or directory

It looks like the kernel build tools step must be missing
a NO_CTF=1 in it's make environment.

John Birrell
freebsd-current at freebsd.org mailing list
To unsubscribe, send any mail to
"freebsd-current-unsubscribe at freebsd.org"

More information about the freebsd-current mailing list