state of 7.0-RC1 on an IBM t60p

Vladimir Grebenschikov vova at
Mon Feb 4 13:00:09 UTC 2008

Looks like I am more lucky, but with just T60

On Sun, 2008-01-06 at 11:02 -0600, Josh Paetzel wrote:
> I recently installed FBSD 7.0-BETA4 on my laptop in an effort to get working 
> intel 3945abg wireless.  I bumped it up to 7.0-RC1 the other day.  I've been 
> in a bit of a state health wise and have gotten to the point where i need to 
> depend on my laptop, so it has to go back to releng_6, but I thought I'd 
> write out the problems I've been having.
> 1) wpi is nearly non-functional.  It seems to associate best to WPA2 networks, 
> struggles with WEP and won't associate at all to open networks.  Once it's 
> associated it spams the console with "discarding packet without header" 
> and "wpi_cmd: couldn't set tx power" quite a bit, as well as other random 
> output.  The real problem I've had with it is that it panics under moderate 
> data rates, in the 1000-1500K/sec range.

Ehh, tried with it, and finally just replace hardware on 'ath0: <Atheros
since that wireless works more or less fine

> 2) pantech px-500 evdo pccard.  This thing uses the ucom/umodem driver and 
> panics after a few seconds of transfer at anything over 30K/sec or so.  It 
> also panics instantly on insertion or removal.  I've been unable to get a 
> crash dump or to the debugger for this, my swap is encrypted and seeming gets 
> cleared before savecore runs, and i've been unable to dump to usb swap 
> devices.  (The card is a pccard that has a usb controller with a usb-> serial 
> adapter on it)

Did not tried such beast, pried another EVDO PCMC card and failed also
(Ubiquam UM-300). FreeBSD detects sio port on card, but does not detects
PCMCI USB hub. Probably I also need to try

> 3) sutdown output is garbled.  This doesn't seem to hurt anything,  but at 
> some point in shutdown the console messages start interleaving.

Never seen that, I am on RELENG_7

> 4) acpi suspend and resume doesn't work, but that's not a huge shock.l

Ehh, only mobile platform that has strong FreeBSD support loose that
Looks like root of problem is CoreDuo CPU, but still no any clues.

> 5) ath generates interrupt storms that are throttled.

See above, works fine for me (in mini-PCI slot).

> wpi0: link state changed to UP
> ath0: <Atheros 5212> mem 0x88000000-0x8800ffff irq 16 at device 0.0
> on 

Did not get, do you have two wireless cards or just try to use two
drivers against single card ?

Also I may say: 
- IBM dock station works for me
- IBM special controls mostly works (brightness, think-light, volume,
- PCMCI card slot works also
- PCI Express slot looks like working, but I have no card to try
- Bluetooth works as well
- radeonhd xorg driver does almost everything I need, except 3D support,
and it is not compatible with brightness control
- SoftModem never works for me
- Touchpad/stick works, even with synaptics driver under X, but
some-times it stop responding

Vladimir B. Grebenschikov
vova at

More information about the freebsd-current mailing list