Panic "rw lock not unlocked" doing NFS mount

Peter Jeremy peterjeremy at
Sun Dec 28 11:09:26 UTC 2008

I'm running -current from just before Christmas and when I tried to
NFS mount a ZFS filesystem, the server panic'd.  Backtrace is:
#9  0xffffffff802be55b in panic (fmt=Variable "fmt" is not available.) at /usr/src/sys/kern/kern_shutdown.c:559
During symbol reading, unsupported tag: 'DW_TAG_volatile_type'.
#10 0xffffffff802bc8f1 in rw_destroy (rw=0xffffffff80a20fe0) at /usr/src/sys/kern/kern_rwlock.c:180
#11 0xffffffff80336636 in vfs_export (mp=0xffffff0001c6a000, argp=0xfffffffe96b10960) at /usr/src/sys/kern/vfs_export.c:247
#12 0xffffffff8033de6f in vfs_donmount (td=0xffffff0001c8dab0, fsflags=0x11100, fsoptions=0xffffff0016c69700) at /usr/src/sys/kern/vfs_mount.c:998
#13 0xffffffff8033eeec in nmount (td=0xffffff0001c8dab0, uap=0xfffffffe96b10c00) at /usr/src/sys/kern/vfs_mount.c:417
#14 0xffffffff8044d12d in syscall (frame=0xfffffffe96b10c90) at /usr/src/sys/amd64/amd64/trap.c:898
#15 0xffffffff8042fd4b in Xfast_syscall () at /usr/src/sys/amd64/amd64/exception.S:338

I'm not sure why nmount(2) is being invoked on the NFS server.  Also, the
path passed into nmount() is not the path I was mounting (though it is a
path I tried unsuccessfully to mount yesterday).  Has anyone got any

Just before I sent this, I tried the mount again and got EPERM on the
client.  Since I'd been renaming ZFS mountpoints, I assumed that mountd
had gotten itself confused.  When I SIGHUP'd it, I got another identical

Peter Jeremy
Please excuse any delays as the result of my ISP's inability to implement
an MTA that is either RFC2821-compliant or matches their claimed behaviour.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
Url :

More information about the freebsd-current mailing list