No sound from snd_hda

Ganbold ganbold at
Tue Dec 23 07:22:47 UTC 2008

Alexander Motin wrote:
> Damian Gerow wrote:
>> I've got an Intel HDA device that is sort-of detected, but I get no 
>> sound
>> from it:
>> -----
>> FreeBSD Audio Driver (newpcm: 64bit 2007061600/amd64)
>> Installed devices:
>> pcm0: <HDA Conexant (Unknown) PCM #0 Analog> at cad 0 nid 1 on hdac0 
>> kld snd_hda [MPSAFE] (1p:1v/1r:1v channels duplex default)
>> pcm1: <HDA Conexant (Unknown) PCM #1 Analog> at cad 0 nid 1 on hdac0 
>> kld snd_hda [MPSAFE] (1p:1v/1r:1v channels duplex)
>> -----
>> The same device looked almost exactly the same on a 7.1-BETA build, 
>> but I
>> actually had audio output.
>> I've checked the mixer device, tried muting and unmuting various 
>> channels,
>> all to no avail.  The audio devices are created, and every program I've
>> tried opens them successfully, but I get no actual sound.
>> I've tried searching around, but I haven't been able to turn anything 
>> up.
>> Is there something I'm missing?  Something I should be doing that I'm 
>> not?
> You are missing new snd_hda man page reading. RTFM. :)
> 1) Read new man page;
> 2) Driver provides you two pcm devices for different purposes, so try 
> to use both (as man page recommends);
> 3) If your system has several audio connectors - try all of them, they 
> are not equal any more.
> 4) Boot with verbose logs enabled to get much more information about 
> your codec and driver operation (as man page recommends);
> 5) Connexant audio codecs are rare, so send your verbose output to me, 
> I would like to see it.

I have same "no audio" problem here with my laptop on CURRENT and
I will play around with device.hints later today.

Just FYI dmesg and pciconf logs:


Laura's Law: No child throws up in the bathroom.

More information about the freebsd-current mailing list