Call for testers: Atheros AR8121(L1E)/AR8113/AR8114(L2E) ethernet

Josh Carroll josh.carroll at
Wed Dec 10 17:45:58 PST 2008

> ale0 at pci0:2:0:0:        class=0x020000 card=0x82261043 chip=0x10261969
> rev=0xb0 hdr=0x00
>    vendor     = 'Attansic (Now owned by Atheros)'
>    class      = network
>    subclass   = ethernet
> iperf (ale0 as -s):  [  3]  0.0-10.0 sec  1.10 GBytes    941 Mbits/sec
> iperf (ale0 as -c):  [  3]  0.0-10.0 sec  1.08 GBytes    931 Mbits/sec
> So all seems well here.

Well, I spoke too soon. Overall gigE throughput wise and day to day
activities (NAT'd 20 Mbit FiOS) were fine.

Tonight, however, I went to watch a 720p video (~4 Mbps bitrate or
less) on my Popcorn Hour over NFS which has worked fine in the past.
It was extremely "jerky" and unwatchable. Figuring perhaps the Popcorn
Hour had an issue, I fired up an NFS server on another box and the
video streamed just fine. I then rebooted this box and threw in a
trusty old PCI em(4) card, and all is well.

I tried playing with these two sysctl knobs for ale0:




I tried setting both to 0 and both to higher numbers on the documented
scale (10000 I believe), neither of which helped. I imagine since what
I want here is a "smoother" transmission, setting int_tx_mod to 0 is
what would have the most effect, but the video still was not playable
with it set to 0.

I've since disabled the ale0 interface in the BIOS and I'm using the
em(4) for now.

Is there another knob for ale I should try adjusting?


More information about the freebsd-current mailing list