Booting from gpt on i386/amd64?

Alexey Shuvaev shuvaev at
Fri Aug 29 20:53:16 UTC 2008

Hello list!

I have tried to install a system with pure gpt partitioning,
but haven't managed to boot from it.

Partition table:

=>       34  976773101  ad6  GPT  (500.1GB)
         34    1571840    1  freebsd-ufs  (804.8MB)
    1571874    8388608    2  freebsd-swap  (4.3GB)
    9960482       1024    3  freebsd-boot  (524.3KB)
    9961506    8388608    4  freebsd-ufs  (4.3GB)
   18350114     524288    5  freebsd-ufs  (268.4MB)
   18874402  134217728    6  freebsd-ufs  (68.7GB)
  153092130  823681005       - free -  (421.7GB)

All necessary files are already installed (ad6p1 = /, ad6p4 = /var, and
so on). The system is 8.0-CURRENT from 8 August (bootable usb flash).
Computer is Core2Duo E8400 3.0 GHz, 4 Gb RAM, ICH9, 500 GB SATA.
What have been done:

gpart bootcode -b /path/to/pmbr ad6

gpart bootcode -p /path/to/gptboot -i 3 ad6
gpart: /dev/ad6p3: Invalid argument

I have tried to 'newfs /dev/ad6p3' and then mounting it and copying
gptboot into 'boot' directory on ad6p3, but looking at the sources it
seems to be wrong.

Then I tried to 'dd if=gptboot of=/dev/ad6p3 bs=512', 
but in all cases during the boot the blinking cursor moves 1 line down
and computer freezes here.

Is it my local problem?
What is the correct procedure of preparing gpt-only BIOS-bootable system?


More information about the freebsd-current mailing list