Inserting flow-control chars with an mpsafetty kernel

Paul B. Mahol onemda at
Tue Aug 26 13:09:57 UTC 2008

On 8/26/08, Giorgos Keramidas <keramida at> wrote:
> On Tue, 26 Aug 2008 14:39:45 +0400, swell.k at wrote:
>> Giorgos Keramidas <keramida at> writes:
>>> Hi Ed,
>>> After installing the mpsafetty changes it seems that flow-control ^S
>>> and ^Q characters cannot be inserted inserted anymore.  I first
>>> noticed this when CTRL-S stopped working as 'search-forward' in
>>> Emacs, but it seems the same problem exists in /usr/bin/vi, vim, bash
>>> and a few other programs that I tested.
>>> With a kernel before the mpsafetty changes, I can fire up /usr/bin/vi
>>> and type in insert-mode `^V^S'.  This correctly inserts a ^S
>>> character.  With a kernel from svn revision /head at 181939 ^V no longer
>>> quotes the next byte in vi(1) and other programs.
>> Could you possibly be trying to type them inside screen(1)? If so, are
>> they working correctly outside it?
> Yes.  I was using screen when I tried this.  Now that I tried outside of
> screen, C-s and C-q work in Emacs and ^V^S or ^V^Q works in /usr/bin/vi.

^V^S and ^V^Q do not work in vim from console (no screen(1) here).
(I think it worked before)

> Is this a known bug of screen?  Are there already patches floating
> around to fix it?
> _______________________________________________
> freebsd-current at mailing list
> To unsubscribe, send any mail to "freebsd-current-unsubscribe at"

More information about the freebsd-current mailing list