No root filesystem

John Baldwin jhb at
Sat Aug 23 20:32:09 UTC 2008

On Saturday 23 August 2008 10:33:32 am Christian Weisgerber wrote:
> Christian Weisgerber <naddy at> wrote:
> > I just tried to update my box, but the new kernel wouldn't find a
> > root device.  This is a rather vanilla amd64 box, no zfs, one SATA
> > disk, no other operating systems.
> >
> > It tried to mount ufs:/dev/ad6s1a, which is correct, but somehow
> > came up empty.  At the "Manual root filesystem specification" prompt,
> > "?" did not list any devices.
> >
> > My previous good kernel is about 48 hours old, so this must have
> > been introduced very recently.
> I've compared dmesgs and these lines are missing when I boot the bad
> kernel:
> k8temp0: <AMD K8 Thermal Sensors> on hostb3
> acd0: DVDR <ASUS DRW-2014L1T/1.00> at ata2-master SATA150
> ad6: 143089MB <WDC WD1500ADFD-00NLR5 21.07QR5> at ata3-master SATA150
> The drives aren't found, so not root filesystem.
> It turns out that the problem is caused by this commit:
>   SVN rev 181987 on 2008-08-22 02:14:23Z by jhb
>   Extend the support for PCI-e memory mapped configuration space access:
> Reverting this fixed the problem.  The drives are found again (and
> so are the thermal sensors).
> The machine is based on an nForce 570 SLI MCP chipset (Asus M2N-SLI
> Deluxe).  Here's the dmesg, minus the witness chatter on root mount:

Does 'acpidump -t' show a MCFG table?  Also, can you get the output 
of 'devinfo -r' (with working kernel).

John Baldwin

More information about the freebsd-current mailing list