[iwn driver] SIOCS80211 error on 4965AGN

Sam Leffler sam at freebsd.org
Thu Aug 14 04:51:13 UTC 2008

Rohit Tripathi wrote:
>> That shoud be... :)
>> ifconfig wlan create wlandev iwn0
> Great! I ran the above and wlan0 was created without any issues. Next
> I tried to setup wlan0 with:
> ssid HAM authmod shared wepmode on weptxkey 1 wepkey blahblah DHCP
> and I first noticed ifconfig complain: "authmod: bad value",  "missing
> or corrupted regdomain database"  and the os complain: "iwn0: need
> multicast update callback"
> ( Here's what came up with a google search on the last error
> http://lists.freebsd.org/pipermail/freebsd-current/2008-April/085152.html
>  http://unix.derkeiler.com/Mailing-Lists/FreeBSD/current/2008-04/msg00554.html
> )

man ifconfig for most of this.  The regdomain database complaint means 
you don't have /etc/regdomain.xml installed which means your system is 
not installed properly.

The iwn complaint can be ignored.

I would not be at all surprised if iwn does not implemented shared key 
auth wep correctly as it's a really bad idea and so likely not tested. 
If wep is your only option I'd just turn it off entirely; it provides 
zero security.


More information about the freebsd-current mailing list