[iwn driver] SIOCS80211 error on 4965AGN

Andrew Thompson thompsa at FreeBSD.org
Thu Aug 14 04:43:46 UTC 2008

On Wed, Aug 13, 2008 at 09:05:44PM -0700, Sam Leffler wrote:
> Rohit Tripathi wrote:
>>> Yes, I'm running current and have compiled both GENERIC for amd64 and
>>> a custom kernel with debugging disabled and iwn driver built in but
>>> neither worked. I have also followed instructions in both
>>> networking-wireless.html and the above entry.
>>> Putting the line
>>> wlans_iwn0=wlan0
>> I tried something else today....manually build and install iwn
>> firmware from sys/modules/iwn, checked that loader.conf has the line
>> legal.intel_iwn.license_ack=1, the device is recognized as iwn0 but I
>> tried to set both wlans_iwn0 and wlans_ath0 to wlan0, but still no
>> luck :( Can someone provide the actual command that is used to create
>> wlan0 alias?
> ifconfig wlan create wlandev iwn0
> ifconfig iwn0 up
> dhclient iwn0

That shoud be... :)

ifconfig wlan create wlandev iwn0
ifconfig wlan0 up
dhclient wlan0

More information about the freebsd-current mailing list