BTX loader crash on AM2 Asus M2N32 WS mainboard

Remko Lodder remko at
Fri Nov 30 12:14:37 PST 2007

Remko Lodder wrote:
> Andre Oppermann wrote:
>> Andrey V. Elsukov wrote:
>>> Andre Oppermann wrote:
>>>> The BTX loader crashes on a brand new AM2 Asus M2N32 WS
>>>> Professional mainboard with nForce790 SLI chipset.  The CPU is AMD
>>> Hm.. I think it's nForce 590.
>> Indeed.
>>>> Athlon 64 X2 4800+.  The system has got an Areca ARC-1220 8-port
>>>> PCI-E SATA2 RAID controller, a Intel PCI-X Pro/1000MT NIC and an
>>>> ATI RV370 based graphics card (Asus EAX1050&TD/256M, PCI-E). RAM is
>>>>  upped to 8GB in 4 times 2GB of Kingston KVR667D2N5/2G (DDR2-667,
>>>> CL5).
>>>> Any suggestions and help appreciated.
>>> Ok. I have the same motherboard and i think your CD drive connected
>>> to the integrated Marvell 88SE6141 controller's port.
>> Yes, the CDROM was connected to the Marvell based PATA port.
>>> It's not supported by the our ATA driver yet. Try to reconnect your
>>> CD drive to the NVIDIA controller's port.
>> That should not make a difference as the kernel isn't yet loaded.
>> It's all within the loader operating through BIOS calls (?).
>> It looks like the Marvell ATA BIOS upsets the loader when booting
>> from one its drives.
>> When reconnecting the CDROM to the nForce based PATA port the loader
>> doesn't crash anymore and the kernel begins to boot until this:
>> atapci0: <nVidia nForce MCP55 UDMA133 controller> port
>> 0x1f0-0x1f7,0x3f6,0x170-0x177, 0x376,0xf400-0xf40f at device 12.0 on pci0
>> ata0: <ATA channel 0> on atapci0
>> ata0: [ITHREAD]
>> ata1: <ATA channel 1> on atapci0
>> ata1: [ITHREAD]
>> ...
>> acd0: DVDR <PIONEER DVD-RW DVR-103/2.00> at ata0-master PIO4
>> ...
>> acd0: FAILURE - READ_BIG MEDIUM ERROR asc=0x11 ascq=0x06
>> GEOM_LABEL: Label for provider acd0 is iso9660/FreeBSD_Install.
>> acd0: FAILURE - READ_BIG MEDIUM ERROR asc=0x11 ascq=0x06
>> then it just hangs (not hard though)...  Have tried it with two
>> different CDROM drivers from different makers with identical results
>> (the other drive is a plain Toshiba DVDROM).  Image is FreeBSD 7.0BETA3
>> AMD64 burned to a CD-R. Exactly the same problem with BETA3 i386.
>> FreeBSD 6.2R i386 boots into the installer successfully.
> I have to admit that on the Other Operating System out there (and it's
> not Linux ;-)) I have a problem with the ATA controller as well, when I
> play a DVD on the device, it will stop after using it 10 minutes and I
> have the same motherboard as you have.
> I'll have a look what happends when I try the install CD for 7.x in both
> a SATA port as the ATA port so that we can ruleout what happends.
> Cheers
> remko

I tried both the i386 as the AMD64 installation CD, on my workstation
and I can get in the installation screen without any problems at all..

>From what I recall from the BIOS settings I dont have the SATA ports
enabled on the Marvell chip fwiw.

Any other suggestions which I can get to see whether I have the same
problem as you have?

/"\   Best regards,                      | remko at
\ /   Remko Lodder                       | remko at EFnet
 X          |
/ \   ASCII Ribbon Campaign              | Against HTML Mail and News

More information about the freebsd-current mailing list