ata(4) support for IXP600 and IXP700

Bruce Cran bruce at cran.org.uk
Mon Nov 26 10:05:17 PST 2007


Martin Matuska wrote:
> Hi all,
> 
> I have several systems with mainboards that use IXP600 and IXP700 SATA
> controllers.
> These arebut not supported by ata(4) yet, I am successfully using the
> proposed patch at
> 
> kern/116125
> ( http://www.freebsd.org/cgi/query-pr.cgi?pr=116125 ).
> 
> The patch works very well on 6-STABLE, 7-STABLE and 8-CURRENT, me and
> several other people are using it for two months now.
> If I can help with more testing to introduce this patch to the tree,
> just tell me what to do.

I recently noticed support for the IXP600 controller was committed to 
RELENG_7, but the name for atapci0 is corrupted on my Dell laptop:

atapci0: 
<\M-PG}\M^@\M^?\M^?\M^?\M^?\M-rv+\M^@\M^?\M^?\M^?\M^?\M-PG}\M^@\M^?\M^?\M^?\M^?\M-^\M-t,\M^@\M^?\M^?\M^?\M^?> 
port 0x8438-0x843f,0x8454-0x8457,0x8430-0x8437,0x8450-0x8453,0x8400-0x840f

atapci1: <ATI IXP600 UDMA133 controller> port 
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x8420-0x842f at device 20.1 on pci0

This is on RELENG_7 from a few days ago:
FreeBSD muon.draftnet 7.0-BETA3 FreeBSD 7.0-BETA3 #1: Sat Nov 24 
02:24:47 GMT 2007     brucec at muon.draftnet:/usr/obj/usr/src/sys/INSPIRON 
  amd64

I've pasted a full dmesg below.

--
Bruce




Copyright (c) 1992-2007 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 7.0-BETA3 #1: Sat Nov 24 02:24:47 GMT 2007
     brucec at muon.draftnet:/usr/obj/usr/src/sys/INSPIRON
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Turion(tm) 64 X2 Mobile Technology TL-52 (1600.07-MHz K8-class CPU)
   Origin = "AuthenticAMD"  Id = 0x40f82  Stepping = 2
 
Features=0x178bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,HTT>
   Features2=0x2001<SSE3,CX16>
   AMD Features=0xea500800<SYSCALL,NX,MMX+,FFXSR,RDTSCP,LM,3DNow!+,3DNow!>
   AMD Features2=0x1f<LAHF,CMP,SVM,ExtAPIC,CR8>
   Cores per package: 2
usable memory = 2003025920 (1910 MB)
avail memory  = 1932935168 (1843 MB)
ACPI APIC Table: <PTLTD  	 APIC  >
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
  cpu0 (BSP): APIC ID:  0
  cpu1 (AP): APIC ID:  1
MADT: Forcing active-low polarity and level trigger for SCI
ioapic0 <Version 2.1> irqs 0-23 on motherboard
kbd1 at kbdmux0
acpi0: <DELL M08    > on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
unknown: I/O range not supported
acpi0: reservation of 0, 1000 (3) failed
ACPI HPET table warning: Sequence is non-zero (2)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <32-bit timer at 3.579545MHz> port 0x8008-0x800b on acpi0
acpi_ec0: <Embedded Controller: GPE 0x14> port 0x62,0x66 on acpi0
acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on 
acpi0
Timecounter "HPET" frequency 14318180 Hz quality 900
cpu0: <ACPI CPU> on acpi0
powernow0: <PowerNow! K8> on cpu0
cpu1: <ACPI CPU> on acpi0
powernow1: <PowerNow! K8> on cpu1
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
vgapci0: <VGA-compatible display> port 0x9000-0x90ff mem 
0xc8000000-0xcfffffff,0xc0100000-0xc010ffff irq 17 at device 5.0 on pci1
pcib2: <ACPI PCI-PCI bridge> at device 5.0 on pci0
pci2: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 6.0 on pci0
pci5: <ACPI PCI bus> on pcib3
pci5: <network> at device 0.0 (no driver attached)
atapci0: 
<\M-PG}\M^@\M^?\M^?\M^?\M^?\M-rv+\M^@\M^?\M^?\M^?\M^?\M-PG}\M^@\M^?\M^?\M^?\M^?\M-^\M-t,\M^@\M^?\M^?\M^?\M^?> 
port 
0x8438-0x843f,0x8454-0x8457,0x8430-0x8437,0x8450-0x8453,0x8400-0x840f 
mem 0xc0004000-0xc00043ff irq 22 at device 18.0 on pci0
atapci0: [ITHREAD]
ata2: <ATA channel 0> on atapci0
ata2: [ITHREAD]
ata3: <ATA channel 1> on atapci0
ata3: [ITHREAD]
ohci0: <OHCI (generic) USB controller> mem 0xc0005000-0xc0005fff irq 16 
at device 19.0 on pci0
ohci0: [GIANT-LOCKED]
ohci0: [ITHREAD]
usb0: OHCI version 1.0, legacy support
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: <ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb0
uhub0: 2 ports with 2 removable, self powered
ohci1: <OHCI (generic) USB controller> mem 0xc0006000-0xc0006fff irq 17 
at device 19.1 on pci0
ohci1: [GIANT-LOCKED]
ohci1: [ITHREAD]
usb1: OHCI version 1.0, legacy support
usb1: <OHCI (generic) USB controller> on ohci1
usb1: USB revision 1.0
uhub1: <ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb1
uhub1: 2 ports with 2 removable, self powered
ohci2: <OHCI (generic) USB controller> mem 0xc0007000-0xc0007fff irq 18 
at device 19.2 on pci0
ohci2: [GIANT-LOCKED]
ohci2: [ITHREAD]
usb2: OHCI version 1.0, legacy support
usb2: <OHCI (generic) USB controller> on ohci2
usb2: USB revision 1.0
uhub2: <ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb2
uhub2: 2 ports with 2 removable, self powered
ohci3: <OHCI (generic) USB controller> mem 0xc0008000-0xc0008fff irq 17 
at device 19.3 on pci0
ohci3: [GIANT-LOCKED]
ohci3: [ITHREAD]
usb3: OHCI version 1.0, legacy support
usb3: <OHCI (generic) USB controller> on ohci3
usb3: USB revision 1.0
uhub3: <ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb3
uhub3: 2 ports with 2 removable, self powered
ohci4: <OHCI (generic) USB controller> mem 0xc0009000-0xc0009fff irq 18 
at device 19.4 on pci0
ohci4: [GIANT-LOCKED]
ohci4: [ITHREAD]
usb4: OHCI version 1.0, legacy support
usb4: <OHCI (generic) USB controller> on ohci4
usb4: USB revision 1.0
uhub4: <ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb4
uhub4: 2 ports with 2 removable, self powered
ehci0: <EHCI (generic) USB 2.0 controller> mem 0xc0004400-0xc00044ff irq 
19 at device 19.5 on pci0
ehci0: [GIANT-LOCKED]
ehci0: [ITHREAD]
usb5: EHCI version 1.0
usb5: companion controllers, 2 ports each: usb0 usb1 usb2 usb3 usb4
usb5: <EHCI (generic) USB 2.0 controller> on ehci0
usb5: USB revision 2.0
uhub5: <ATI EHCI root hub, class 9/0, rev 2.00/1.00, addr 1> on usb5
uhub5: 10 ports with 10 removable, self powered
pci0: <serial bus, SMBus> at device 20.0 (no driver attached)
atapci1: <ATI IXP600 UDMA133 controller> port 
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x8420-0x842f at device 20.1 on pci0
ata0: <ATA channel 0> on atapci1
ata0: [ITHREAD]
pcm0: <ATI SB600 High Definition Audio Controller> mem 
0xc0000000-0xc0003fff irq 16 at device 20.2 on pci0
pcm0: [ITHREAD]
isab0: <PCI-ISA bridge> at device 20.3 on pci0
isa0: <ISA bus> on isab0
pcib4: <ACPI PCI-PCI bridge> at device 20.4 on pci0
pci8: <ACPI PCI bus> on pcib4
bfe0: <Broadcom BCM4401-B0 Fast Ethernet> mem 0xc0300000-0xc0301fff irq 
21 at device 0.0 on pci8
miibus0: <MII bus> on bfe0
bmtphy0: <BCM4401 10/100baseTX PHY> PHY 1 on miibus0
bmtphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
bfe0: using obsoleted if_watchdog interface
bfe0: Ethernet address: 00:19:b9:54:f0:4a
bfe0: [ITHREAD]
pci8: <base peripheral> at device 1.0 (no driver attached)
pci8: <base peripheral> at device 1.1 (no driver attached)
acpi_button1: <Sleep Button> on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_acad0: <AC Adapter> on acpi0
battery0: <ACPI Control Method Battery> on acpi0
acpi_tz0: <Thermal Zone> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: [ITHREAD]
psm0: model Generic PS/2 mouse, device ID 0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xccfff,0xcd000-0xcdfff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ums0: <Microsoft Microsoft 3-Button Mouse with IntelliEye(TM), class 
0/0, rev 1.10/3.00, addr 2> on uhub0
ums0: 3 buttons and Z dir.
Timecounters tick every 1.000 msec
acd0: DVDR <HL-DT-ST DVD+/-RW GSA-T11N/A102> at ata0-master UDMA33
ad4: 114473MB <SAMSUNG HM120JI YF100-15> at ata2-master UDMA33
pcm0: <HDA Codec: Sigmatel STAC9220>
pcm0: <HDA Driver Revision: 20071020_0048>
SMP: AP CPU #1 Launched!
hwpmc: TSC/1/0x20<REA> K8/4/0x1ff<INT,USR,SYS,EDG,THR,REA,WRI,INV,QUA>
Trying to mount root from ufs:/dev/ad4s2a


More information about the freebsd-current mailing list