RELENG_7 and HEAD: bge causes system hang

Cristian KLEIN cristi at
Mon Nov 26 07:08:55 PST 2007

Jung-uk Kim wrote:
> On Wednesday 14 November 2007 07:49 am, Andrey wrote:
>> Thanks for willingness to help!
>> I've tried to play with hw.bge.allow_asf sysctl option many times
>> on many snapshots of 7-th branch (200708, 200709, 200710,
>> 7.0-BETA1.5, 7.0-BETA2). More that each time I tracked changes in
>> CVS assumed to be related with the problem I csup'ed sources and
>> tried again and again. Even changing corresponding code inside of
>> sys/dev/bge/if_bge.c (I mean string that currently looks like
>> "static int bge_allow_asf = 0;") didn't help.
>> I know it helps other people who had similar porblems on their HP
>> machines with other Broadcom's NIC's. But unfortunately such a
>> solution does not fit my case :o(.
>> Jeremy Chadwick wrote:
>>> This is a shot in the dark, but try putting the following in
>>> /boot/loader.conf:
>>> hw.bge.allow_asf=1
>>> If /boot/loader.conf already has that in it, try a value of 0
>>> instead.
> Please try:

Great to hear this problem was solved. I still have one big fat question. Why
did the system hang and not allow the kernel debugger show up? I strongly
believe that this bug would have been easily spotted suppose KDB would have
responded. Is it perhaps possible to "harden" KDB, so that such issues are
easier to find and fix in future?

More information about the freebsd-current mailing list