snd_hda + ath = hard hang

Kostik Belousov kostikbel at gmail.com
Sun Nov 25 12:19:22 PST 2007


I have a laptop that shares interrupt between ath0 and snd_hda0 devices.
Machine works under the RELENG_6 normally. Now, on the RELENG_7 (and
CURRENT), attempt to ifconfig ath0 up usualy hangs the machine in the
next 2-5 minutes.

Hang is hard, I even cannot switch the console to look at the kernel
messages or enter the ddb. Also, laptop does not have a serial port.

Not setting the ath0 up, or, unloading snd_hda.ko before activating
the interface, allows machine to work. Wireless works without problem,
interrupt rate is as expected.

Any advice ?

pciconf:

hostb0 at pci0:0:0:0:	class=0x060000 card=0x00901025 chip=0x27a08086 rev=0x03 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '955XM/945GM/PM/GMS/940GML Express Processor to DRAM Controller'
    class      = bridge
    subclass   = HOST-PCI
none0 at pci0:0:27:0:	class=0x040300 card=0x00901025 chip=0x27d88086 rev=0x02 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82801G (ICH7 Family) High Definition Audio'
    class      = multimedia
ath0 at pci0:6:2:0:	class=0x020000 card=0x04181468 chip=0x001a168c rev=0x01 hdr=0x00
    vendor     = 'Atheros Communications Inc.'
    device     = 'Atheros AR5005G Atheros AR5005G 802.11abg NIC Chipset / TP-Link (TL-WN551G)'
    class      = network
    subclass   = ethernet
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20071125/ef9aa6ba/attachment.pgp


More information about the freebsd-current mailing list