7.0-BETA3 (amd64): interrupt storm on atapci0

Martin Matuska mm at FreeBSD.org
Sat Nov 24 03:05:14 PST 2007


after ca. one day of operation I start experiencing an interrupt storm
on my SB600 SATA controller.
"systat -v" reports around 470k interrupts on atapci0 (irq22).
Error messaage: interrupt storm detected on "irq22:"; throttling
interrupt source.

The interrupt rate shown in "vmstat -i" keeps increasing steadily at
about 5 per second.

I have already tried the following without positive results:
1. tried both of the two available timers, ACPI-Safe and HPET.
2. tried the latest ACPICA patch (acpica-import-20071114.diff)
3. I use the patch from kern/118193 (
http://www.freebsd.org/cgi/query-pr.cgi?pr=kern/118193 ). Without that
patch, the controller runs in UDMA33 mode, but this has no effect on the
interrupt storm that occurs after ca. one day of operation.

In the dmesg output there are unattached devices, if I attach USB, the
problem is not solved.

OS: FreeBSD 7.0-BETA3 amd64 as of today
CPU: AMD Athlon X2 5600+ in SMP mode
Mainboard: MSI MS-7368 (K9AG Neo2-Digital) with the AMD 690G chipset.

"dmesg", "vmstat -i" and "systat -v" outputs are attached.

What might be the cause?
What should I do to debug this problem?
-------------- next part --------------
    1 users    Load  0.05  0.09  0.12                  Nov 24 11:44

Mem:KB    REAL            VIRTUAL                       VN PAGER   SWAP PAGER
        Tot   Share      Tot    Share    Free           in   out     in   out
Act  472716   36772  1107084    53808 1005348  count
All  601696  113500  5910668   234920          pages
Proc:                                                            Interrupts
  r   p   d   s   w   Csw  Trp  Sys  Int  Sof  Flt    159 cow    474k total
          4 103      4243  393  471 470k 1012  375    156 zfod        atkbd0 1
                                                          ozfod       acpi0 irq9
 2.9%Sys   0.4%Intr  0.2%User  0.0%Nice 96.5%Idle        %ozfod  470k atapci0 22
|    |    |    |    |    |    |    |    |    |    |       daefr  2001 cpu0: time
=+                                                    134 prcfr     7 re0 irq256
                                        31 dtbuf      389 totfr  2001 cpu1: time
Namei     Name-cache   Dir-cache    200000 desvn          react
   Calls    hits   %    hits   %    134476 numvn          pdwak
     937     937 100                 24982 frevn          pdpgs
Disks   ad4   ad6                                  436196 wire
KB/t   0.50  0.50                                  470504 act
tps       0     0                                 2091520 inact
MB/s   0.00  0.00                                   13484 cache
%busy     0     0                                  991864 free
                                                   219632 buf

-------------- next part --------------
interrupt                          total       rate
irq1: atkbd0                          11          0
irq9: acpi0                            1          0
irq22: atapci0                2345651167      23043
cpu0: timer                    199854076       1999
irq256: re0                       459211          4
cpu1: timer                    199853873       1999
Total                         1871024631      18719
-------------- next part --------------
Copyright (c) 1992-2007 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 7.0-BETA3 #25: Thu Nov 22 19:32:43 CET 2007
    root at somewhere:/usr/obj/usr/src/sys/KERNEL
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 5600+ (2800.68-MHz K8-class CPU)
  Origin = "AuthenticAMD"  Id = 0x40f33  Stepping = 3
  AMD Features=0xea500800<SYSCALL,NX,MMX+,FFXSR,RDTSCP,LM,3DNow!+,3DNow!>
  AMD Features2=0x1f<LAHF,CMP,SVM,ExtAPIC,CR8>
  Cores per package: 2
usable memory = 4252438528 (4055 MB)
avail memory  = 4097650688 (3907 MB)
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
ioapic0 <Version 2.1> irqs 0-23 on motherboard
kbd1 at kbdmux0
acpi0: <M S I OEMRSDT> on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, ddf00000 (3) failed
ACPI HPET table warning: Sequence is non-zero (2)
Timecounter "ACPI-safe" frequency 3579545 Hz quality 850
acpi_timer0: <32-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
Timecounter "HPET" frequency 14318180 Hz quality 900
cpu0: <ACPI CPU> on acpi0
acpi_throttle0: <ACPI CPU Throttling> on cpu0
acpi_throttle0: CLK_VAL field overlaps THT_EN bit
device_attach: acpi_throttle0 attach returned 6
powernow0: <PowerNow! K8> on cpu0
cpu1: <ACPI CPU> on acpi0
powernow1: <PowerNow! K8> on cpu1
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
vgapci0: <VGA-compatible display> port 0xc000-0xc0ff mem 0xfc000000-0xfdffffff,0xfe9f0000-0xfe9fffff,0xfe800000-0xfe8fffff irq 18 at device 5.0 on pci1
pci1: <multimedia> at device 5.2 (no driver attached)
pcib2: <ACPI PCI-PCI bridge> at device 7.0 on pci0
pci2: <ACPI PCI bus> on pcib2
re0: <RealTek 8168/8111B PCIe Gigabit Ethernet> port 0xd800-0xd8ff mem 0xfeaff000-0xfeafffff irq 19 at device 0.0 on pci2
re0: Using 2 MSI messages
miibus0: <MII bus> on re0
rgephy0: <RTL8169S/8110S/8211B media interface> PHY 1 on miibus0
rgephy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
re0: Ethernet address: 00:19:db:f5:9c:ca
re0: [FILTER]
re0: [FILTER]
atapci0: <ATI IXP600 SATA300 controller> port 0xb000-0xb007,0xa000-0xa003,0x9000-0x9007,0x8000-0x8003,0x7000-0x700f mem 0xfe7ff800-0xfe7ffbff irq 22 at device 18.0 on pci0
atapci0: [ITHREAD]
atapci0: AHCI Version 01.10 controller with 4 ports detected
ata2: <ATA channel 0> on atapci0
ata2: [ITHREAD]
ata3: <ATA channel 1> on atapci0
ata3: [ITHREAD]
ata4: <ATA channel 2> on atapci0
ata4: [ITHREAD]
ata5: <ATA channel 3> on atapci0
ata5: [ITHREAD]
pci0: <serial bus, USB> at device 19.0 (no driver attached)
pci0: <serial bus, USB> at device 19.1 (no driver attached)
pci0: <serial bus, USB> at device 19.2 (no driver attached)
pci0: <serial bus, USB> at device 19.3 (no driver attached)
pci0: <serial bus, USB> at device 19.4 (no driver attached)
pci0: <serial bus, USB> at device 19.5 (no driver attached)
pci0: <serial bus, SMBus> at device 20.0 (no driver attached)
atapci1: <ATI IXP600 UDMA133 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xff00-0xff0f at device 20.1 on pci0
ata0: <ATA channel 0> on atapci1
ata0: [ITHREAD]
isab0: <PCI-ISA bridge> at device 20.3 on pci0
isa0: <ISA bus> on isab0
pcib3: <ACPI PCI-PCI bridge> at device 20.4 on pci0
pci3: <ACPI PCI bus> on pcib3
acpi_button0: <Power Button> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
cryptosoft0: <software crypto> on motherboard
orm0: <ISA Option ROM> at iomem 0xcd800-0xce7ff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounters tick every 1.000 msec
Fast IPsec: Initialized Security Association Processing.
ad4: 381554MB <SAMSUNG HD401LJ ZZ100-15> at ata2-master SATA300
ad6: 381554MB <SAMSUNG HD401LJ ZZ100-15> at ata3-master SATA300
SMP: AP CPU #1 Launched!
Trying to mount root from ufs:/dev/ad4s1a
re0: link state changed to UP

More information about the freebsd-current mailing list