ALTQ problem on 7.0-BETA3

Gabriel Linder linder at
Tue Nov 20 02:50:38 PST 2007


I had some spare time yesterday, and wanted to tweak my outgoing
traffic. So I recompiled my kernel with ALTQ (kernel conf here [1]), and
edited my working pf.conf[2] to add queuing. As you can see, I use the
BFE(4) driver, which is reported to work in ALTQ(4). I included the
ALTQ_NOPCC option because I was not sure if I need in or not, I think I
don't need it (without it, everything works well). I tried with both
4BSD and ULE, too.

Here is my problem : with queing enabled (which seems to work
perfectly), my downloads connections are reseted by the peer each
~200MB. I checked this with wget : to download the BETA3 iso it has 4
retries each ~200MB.

The strange thing is that on my Slackware laptop, the same ISO from the
same mirror downloads just fine, without any problem. And when I tried
to download this ISO from my Slackware laptop's ftp (using my LAN), it
was fine too.

If I disable the queuing rules in my pf.conf, the download is just fine
with FreeBSD too. And when re-enabling these rules, the download is broken.

Or maybe I am just doing something wrong with my queues ?

I attached a dmesg[3] by the way (Acer Aspire 5610).

PS : Congrats for the ULE scheduler, I tried it too and I can now make
-j8 build{world,kernel} without any problem on a Core Duo laptop ! With
4BSD the mouse and keyboard were kind of sloppy :)

[1] :
[2] :
[3] :

More information about the freebsd-current mailing list