RELENG_7 and HEAD: bge causes system hang

Andrey Kosachenko andrey.kosachenko at gmail.com
Fri Nov 16 15:38:15 PST 2007


Good time of the day, Jung-uk Kim!

Thank you for good news!

I've just tried fresh revision of sys/dev/pci/pci.c you pointed me to
and it solved the problem for me. Actually, now I can state that there
is no problem "bge causes system hang" on RELENG_7 with bge driver (on
HP machine with Broadcom Netlink Gigabit Ethernet, chipset BCM5787).

There are several excerpts below(I think you may be interested in):

------------
# dmesg
...
pcib2: <ACPI PCI-PCI bridge> irq 18 at device 28.2 on pci0
pci24: <ACPI PCI bus> on pcib2
pci0:24:0:0: failed to read VPD data.
bge0: <Broadcom BCM5754/5787 A2, ASIC rev. 0xb002> mem
0xe4000000-0xe400ffff irq 18 at device 0.0 on pci24
miibus0: <MII bus> on bge0
brgphy0: <BCM5787 10/100/1000baseTX PHY> PHY 1 on miibus0
brgphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT,
1000baseT-FDX, auto
bge0: Ethernet address: 00:1a:4b:66:1b:0e
bge0: [ITHREAD]
...
------------
# pciconf -lv
...
bge0 at pci0:24:0:0:       class=0x020000 card=0x30c0103c chip=0x169314e4
rev=0x02 hdr=0x00
     vendor     = 'Broadcom Corporation'
     device     = 'BCM 5787A Ethernet Controller Broadcom Netlink Gigabit'
     class      = network
     subclass   = ethernet
...
------------
# ifconfig bge0
bge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
         options=9b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
         ether 00:1a:4b:66:1b:0e
         inet 10.10.0.2 netmask 0xffffff00 broadcast 10.10.0.255
         media: Ethernet autoselect (100baseTX <full-duplex>)
         status: active
------------

So, great work :o).
Thank you.


Jung-uk Kim wrote:
> 
> Please try:
> 
> http://www.freebsd.org/cgi/cvsweb.cgi/src/sys/dev/pci/pci.c.diff?r1=1.355;r2=1.356
> 
> Jung-uk Kim

--
Sincerely,
Andrey


More information about the freebsd-current mailing list