link() not increasing link count on NFS server

Adam McDougall mcdouga9 at egr.msu.edu
Thu Nov 15 00:04:25 PST 2007


On Wed, Nov 14, 2007 at 11:45:50PM -0800, Kip Macy wrote:

  On Nov 14, 2007 11:42 PM, Adam McDougall <mcdouga9 at egr.msu.edu> wrote:
  > Hi, lately I've been trying to work out some NFS multiple access issues relating
  > to the Dovecot IMAP server software.  One symptom seems to be an unusual behavior
  > of FreeBSD NFS clients that I cannot reproduce with Linux or Solaris NFS clients.
  > Basically, Timo (cc'ed) came up with a small test case that seems to indicate
  > sometimes a link() call can succeed while the link count of the file will not
  > increase.  If this is ran on two FreeBSD clients from the same NFS directory, you
  > will occasionally see "link() succeeded, but link count=1".  I've tried both a
  > Netapp and a FreeBSD NFS server.  I've tried FreeBSD 7_RELENG clients as well as
  > FreeBSD 6.2-stable from this summer.  I've ran it on 32bit and 64bit clients.
  > I've turned rpc.lockd on and off, tried tcp vs. udp mounts, nothing so far seems
  > to make a difference, except perhaps FreeBSD 7.0 seems to produce the error less
  > often.  If one of the processes is ran on a non-FreeBSD NFS cliemt, only the
  > FreeBSD NFS client gives the link error.  Anyone have any input?  Thanks.
  
  Is this with both TCP and UDP clients? We're planning on making the default TCP.
  
  
  -Kip
  
Yes, I saw no difference when using TCP vs UDP.  


More information about the freebsd-current mailing list