ZFS from FreeBSD -> Indiana -> FreeBSD - some problem

Adam McDougall mcdouga9 at egr.msu.edu
Wed Nov 14 17:52:20 PST 2007

Henri Hennebert wrote:
> Henri Hennebert wrote:
>> Hello,
>> As seen in another thread, I was curious about a zpool created under 
>> FreeBSD being available under opensolaris.
>> So I boot indiana and do:
>> zpool import -f -o ro pool2
>> zpool scrub pool2
>> all ended properly...
>> shutdown.
>> When I reboot with FreeBSD (7.0-BETA2) I get:
>> zpool status pool2
>>   pool: pool2
>>  state: UNAVAIL
>> status: One or more devices could not be opened.  There are insufficient
>>         replicas for the pool to continue functioning.
>> action: Attach the missing device and online it using 'zpool online'.
>>    see: http://www.sun.com/msg/ZFS-8000-D3
>>  scrub: none requested
>> config:
>>         NAME             STATE     READ WRITE CKSUM
>>         pool2            UNAVAIL      0     0     0  insufficient 
>> replicas
>>           raidz1         UNAVAIL      0     0     0  insufficient 
>> replicas
>>             dsk/c10d0p3  UNAVAIL      0     0     0  cannot open
>>             dsk/c11d0p3  UNAVAIL      0     0     0  cannot open
>> Is it possible to replace dsk/c10d0p3 by ad4s3 and dsk/c11d0p3 by 
>> ad6s3 as it must be under FreeBSD or does I need to make some entry 
>> in /etc/devfs.rules to create dsk/c10d0p3 and dsk/c11d0p3 (if at all 
>> possible?)
>> Isn't it a interesting challenge ?
> I got it:
> zpool export pool2 && zpool import -f pool2
> do the trick
> sorry for the noise :-|
> Henri
For what its worth, I ran across a similar issue.  I moved a scsi card 
in my server which caused da2 and da3 (each with a separate zfs pool 
with no redundancy) become swapped, which I did not predict.  ZFS was 
completely confused by this, and rather than swap cables and reboot, I 
decided to try the export and import.  Worked fine.  I was a little 
dissapointed and surprised that I had to take action, but more surprised 
that such a simple fix was possible (yet predicted) when the error 
message on sun's website basically indicated 'you are totally screwed, 
game over, data lost'.  I wasn't in a situation were I would have lost 
any valuable data.  Maybe it was terminally confused because both 
devices it wanted were in use by the other 'failed' pool.

More information about the freebsd-current mailing list